Contents

General Information 1-1
Operation Example 2-1
Project (File) Management 3-1
Program Input and Editing 4-1
Table Entry and Editing 5-1
Comments Information 6-1
Manipulating the Display of the Ladder Diagram 7-1
Testing of Application Programs 8-1
Operation of the Controller 9-1
Ladder Program Simulation 10-1
Constructing Projects 11-1
Tabular Outputs 12-1
Auxiliary Functions 13-1
Import and Export Project Contents 14-1
Managing the Desktop 15-1
Common Q&A’s (FAQ) 16-1
Appendix 17-1
WinProladder for WSZ User’s Manual

Contents

Chapter 1: General Information ................................................................. 1-1
  1.1 Operation Environment Requirements ................................................. 1-1
    1.1.1 Operating System .......................................................................... 1-1
    1.1.2 Hardware Requirements ................................................................. 1-1
  1.2 Introduction to Functions and Characteristics ....................................... 1-1
    1.2.1 General Characteristics ................................................................. 1-1
    1.2.2 Software Program Editing .............................................................. 1-1
    1.2.3 Program Testing ............................................................................ 1-2
    1.2.4 Program Comments and Printing ................................................... 1-2
  1.3 Introduction to the operation desktop .................................................... 1-3
  1.4 How the Manual is Arranged ............................................................... 1-4

Chapter 2: Operation Example ............................................................... 2-1
  2.1 Description of Example Program ......................................................... 2-1
  2.2 Create a Project .................................................................................. 2-2
  2.3 Input and Edit the Example Program .................................................... 2-3
    2.3.1 Using Your Mouse to Input and Edit the Example Program .......... 2-3
    2.3.2 Input and Edit the Example Program Using Your Keyboard ......... 2-5
  2.4 Annotating the Example Program ...................................................... 2-7
  2.5 Testing and Debugging ....................................................................... 2-11
  2.6 Printing the Example Program ........................................................... 2-14

Chapter 3: Project (File) Management .................................................... 3-1
  3.1 Establish New Project .......................................................................... 3-1
  3.2 Open File ........................................................................................... 3-2
    3.2.1 Offline Operation ........................................................................... 3-2
    3.2.2 Connection ................................................................................... 3-4
  3.3 Save Project ....................................................................................... 3-6
  3.4 Save As .............................................................................................. 3-6
    3.4.1 Save to Storage Disk ................................................................. 3-7
    3.4.2 Save to Controller ................................................................. 3-7
Chapter 4: Program Input and Editing

4.1 On-line and Off-line Editing

4.2 Input via Mouse and Hot Key Operation
   4.2.1 Inputting Via Mouse
   4.2.2 Input via Hot Keys

4.3 Main Program and Sub Program Unit Operations
   4.3.1 Establish a New Program Unit
   4.3.2 Program Unit Deletion
   4.3.3 Adjust the Order of the Program Units
   4.3.4 Modify Program Unit Name
   4.3.5 Enter Program Unit Comments

4.4 Contact Components Operations
   4.4.1 Input Contact Component
   4.4.2 Change the Type or Reference Number of the Contact Component
   4.4.3 Deleting Contact Components

4.5 Usage of Function Block Instructions
   4.5.1 Input Function Block Instructions
   4.5.2 Editing Function Block Instruction
   4.5.3 Delete Function Block Instruction

4.6 Usage of Step Ladder Instructions
   4.6.1 Input Step Ladder Stages (STP Instruction)
   4.6.2 Input Convergence (From Instruction)
   4.6.3 Input Divergence (TO Instruction)

4.7 Editing Mode
   4.7.1 Replace Mode
   4.7.2 Insertion Mode

4.8 Changing of Components and Reference Numbers

4.9 Searching for Components
   4.9.1 Search One at a Time in the Current Program Unit
   4.9.2 Batch Searching in Projects

4.10 Network Operations
   4.10.1 Copy Single Network
   4.10.2 Copy Multiple Networks
   4.10.3 Copying Networks from Different Projects
   4.10.4 Deleting Networks
   4.10.5 Network Row and Column Editing
   4.10.6 Insert Blank Network
   4.10.7 Insert Network Comments
   4.10.8 Network Searching
Chapter 5: Table Entry and Editing ................................................. 5-1

5.1 ASCII Table ................................................................................................. 5-1
   5.1.1 New ASCII Table........................................................................................ 5-1
   5.1.2 Modify ASCII Table Name ........................................................................ 5-3
   5.1.3 Delete ASCII Table.................................................................................... 5-4

5.2 Link Table ........................................................................................................ 5-6
   5.2.1 General CPU LINK Communication Table .............................................. 5-6
   5.2.2 High-speed CPU LINK Communication Table .......................................... 5-11
   5.2.3 General Purpose Link Table (Mode1,2) .................................................... 5-13
   5.2.4 ModBus Master Communication Table ..................................................... 5-15

5.3 Servo Parameter Table .................................................................................... 5-17
   5.3.1 Create New Servo Parameter Table ............................................................. 5-17
   5.3.2 Modify Servo Parameter Table Name .......................................................... 5-18
   5.3.3 Delete Servo Parameter Table ................................................................... 5-18

5.4 Servo Program Table ..................................................................................... 5-18
   5.4.1 Create New Servo Program Table ............................................................... 5-18
   5.4.2 Modify Servo Program Table Name ............................................................ 5-21
   5.4.3 Delete Servo Program Table ..................................................................... 5-21

5.5 Register Table .................................................................................................. 5-21
   5.5.1 Create New Register Table ........................................................................ 5-21
   5.5.2 Modify Register Table Name ..................................................................... 5-23
   5.5.3 Delete Register Table ................................................................................ 5-23

5.6 Table Configuration .......................................................................................... 5-23

5.7 Creating and Bringing Up Tables in the Ladder Diagram Using Hotkeys ............ 5-24

Chapter 6: Comments Information ................................................................. 6-1

6.1 Program Unit Comment .................................................................................. 6-1

6.2 Network Comment .......................................................................................... 6-2
   6.2.1 Enter Network Comment Mode of Operation ........................................... 6-2
   6.2.2 Choose Single Network Comment Mode of Operation ............................. 6-3

6.3 Element Comment ........................................................................................... 6-3

6.4 Show Comments ............................................................................................. 6-8
Chapter 7: Manipulating the Display of the Ladder Diagram ....... 7-1

7.1 Usage of the Windows................................................................. 7-1
  7.1.1 Create Multiple Ladder Diagram Display Windows ......... 7-1
  7.1.2 The Order of Display for Ladder Diagram Display Windows ...... 7-2
7.2 Manipulation of the Comments Display in Ladder Diagram Display Windows .... 7-4
  7.2.1 Manipulation of Program Unit Comments Displays .... 7-4
  7.2.2 Manipulation of the Network Comments Display .......... 7-5
  7.2.3 Manipulation of Element Comments Displays ............. 7-5
7.3 Manipulation of the Display of Register Data ......................... 7-6
7.4 Direct Display of Specific Program Points ............................. 7-7
  7.4.1 Locating Elements through Program Units ................. 7-7
  7.4.2 Locating via Program Labels .......................................... 7-8
  7.4.3 Locating via Steps ....................................................... 7-9
7.5 Select Display fonts ............................................................... 7-9
7.6 Mnemonic Code Display Control ............................................. 7-9

Chapter 8: Testing of Application Programs ......................... 8-1

8.1 On-Line Testing........................................................................... 8-1
8.2 Run Time Status Display .......................................................... 8-1
  8.2.1 Bright Display of Conductive Components .................. 8-1
  8.2.2 Current Register Value Display ........................................ 8-2
  8.2.3 Component Enable/Disable Status Display ................. 8-2
8.3 Usage of the Status Monitoring Page ........................................ 8-3
  8.3.1 Status Monitoring Page Management ......................... 8-3
  8.3.2 Defining and Deletion of Monitor Points ....................... 8-5
  8.3.3 Monitor Point Status Display Format Control .......... 8-5
  8.3.4 Entering the Monitor Point Status ................................. 8-9

Chapter 9: Operation of the Controller ........................................ 9-1

9.1 On-Line ..................................................................................... 9-1
  9.1.1 Direct Usage of Existing Connection Settings Files .... 9-1
  9.1.2 Modify Existing Connection Settings Files ................. 9-1
  9.1.3 Create a New Connection Settings File ......................... 9-2
9.2 Off-Line .................................................................................. 9-6
9.3 Run Controller ......................................................................... 9-6
9.4 Stop Controller ....................................................................... 9-6
9.5 Clear Controller ..................................................................... 9-6
9.6 Controller Setting ............................................................................................................ 9-7
  9.6.1 Setting-PLC ID ..................................................................................................... 9-7
  9.6.2 Setting-Station Number ........................................................................................ 9-7
  9.6.3 Setting-Port Parameters ...................................................................................... 9-7
  9.6.4 Setting-Protocol ................................................................................................... 9-8
  9.6.5 Setting-Calendar .................................................................................................. 9-8
  9.6.6 Setting-Phone Number ........................................................................................ 9-9
9.7 Quick Control ............................................................................................................. 9-10
  9.7.1 Get System Status of Controller ......................................................................... 9-10
  9.7.2 Initialize Controller ............................................................................................. 9-11

Chapter 10: Ladder Program Simulation ......................................................... 10-1

  10.1 Features ................................................................................................................. 10-1
  10.2 Limitation of Program Simulation ................................................................. 10-1
  10.3 Operation of Program Simulation ........................................................................ 10-1
    10.3.1 Open Ladder Program ............................................................................... 10-1
    10.3.2 Enter Simulation Mode ............................................................................ 10-2
    10.3.3 Start Execution of Program Simulation ....................................................... 10-2
    10.3.4 Pause of Program Simulation ..................................................................... 10-2
    10.3.5 Proceed to Program Simulation ................................................................. 10-3
    10.3.6 Control Scanning ..................................................................................... 10-3
    10.3.7 Set Address Breakpoint of Program Execution ........................................ 10-4
    10.3.8 View Address Breakpoint List .................................................................... 10-4
    10.3.9 Setup Data Breakpoint .............................................................................. 10-5
    10.3.10 Stop Simulation ...................................................................................... 10-6
    10.3.11 End Simulation ............................................................................................ 10-6
  10.4 Communicate with Simulation Program ............................................................ 10-6
    10.4.1 Communication Function Setup ............................................................... 10-6

Chapter 11: Constructing Projects ................................................................. 11-1

  11.1 Modifying Project Information ........................................................................... 11-1
  11.2 Program Security Settings .................................................................................. 11-1
    11.2.1 Set the Program Password ....................................................................... 11-1
    11.2.2 Set the Program ID .................................................................................... 11-2
  11.3 Program Conversion ............................................................................................ 11-2
  11.4 Set System Configurations .................................................................................. 11-3
    11.4.1 Set I/O Configuration ............................................................................... 11-3
    11.4.2 Configure the Memory Allocation Settings ............................................. 11-12
Chapter 1 General Information

1.1 Operation Environment Requirements

1.1.1 Operating System

- Win95/98/Me/XP/Vista/Win7 or WinNT4.0,Win2000

1.1.2 Hardware Requirements

- Pentium 133 or faster CPU
- At least 256 MB of DRAM memory
- At least 30 MB disk space

1.2 Introduction to Functions and Characteristics

1.2.1 General Characteristics

- For use in a Windows operating environment, completely designed in accordance with Windows environment operation methods and habits, easy to learn and use, and allows users of all types, beginner or expert, to operate the software in a very efficient manner.
- We use a project oriented approach, presenting your software development content visually in a ladder diagram display, facilitating the clear and simple display of the content. All project content, be it for software development or for program maintenance, can be viewed and worked on in an intuitive and straight-forward manner.
- We provide a unique and specially designed keyboard and mouse that is specifically tailored to match and suit your specific office environment conditions, so that no matter what type of environment the user is in, they will always be able to program and test their software in a very efficient manner.
- We provide a diverse set of connection methods, including direct connection, modem connection, and internet connection, etc., and also allow the user to save their connection settings (such as transmission speed, telephone number, web address and IP, etc.) using a file name of their choice, so that next time they need to use the same connection, they only need to pick out the connection settings file from the saved files and will directly be able to proceed with the rest of the connection process.

1.2.2 Software Program Editing

- We provide a run time on-line software program editing feature, in which the user can immediately execute the program without having to re-download, significantly shortening the time needed for development and modifications.
- We provide a multi-window ladder diagram display, which allows the user to display program segments from different
sections for comparison, reproduction, and editing.

- We provide a flexible ladder diagram program edit function which can execute high-end operations such as internet insertion, copying, pasting, and deletion, dramatically increasing program input speed.
- We provide a programming unit insertion function allowing users to categorize their overall development projects into several programming units (according to functionality or any other categorization method) that are capable of performing isolated comment insertion and testing, providing a great help to the development process and subsequent management process of software programs.
- We provide independent mnemonic display windows, allowing the use to display equivalent mnemonic codes according to the location of their cursor in the network of ladder diagram programming windows.
- Diverse program search functions, allowing the user to search devices and registers, and also allowing the setting of filter criteria such as device type, etc., with the search results appearing in tabular form. If the user were to directly click on the search result of their choice, they would be able to call out and display the corresponding code in a ladder diagram window.
- We provide programming syntax checking functionality, which executes when the user decides they would like to perform a check, and also, when the user issues an operation order, the system will automatically execute the syntax check. After the completion of its execution, it will display a syntax check report window, with all the errors being listed out one by one. If the user were to click on one of the listed syntax errors, they could call out the corresponding section of code where the syntax error had occurred with the cursor placed exactly on top of the error. This function is a very significant development for discovering and correcting errors.

### 1.2.3 Program Testing

- We provide multiple status testing windows, allowing the user to specify which component and register information that they would like to have displayed, and also allowing them to specify their data display preferences. The settings for the status testing page will be stored inside the project files, and the next time the user needs to access these settings, they can simply open the previously saved files, making the monitoring and configuration of statuses much more convenient. During execution, the user can disable, enable, or forcefully set a switching device, and set register values.
- In addition to marking the various contact components that are closed using the color red directly on the component, the multi-window high-brightness ladder diagram display also displays the register value of each of its windows, which is a great help for program testers. Inside the window, the user can also directly click on a contact component and disable, enable, or forcefully set it, and the node and circuit of the disabled component will be displayed differently from the other normal components, which is very helpful for handling the status of different components.

### 1.2.4 Program Comments and Printing

- We provide different degrees of comment capabilities, namely, component, register, network, programming unit, and program comments, and all except the last one can be displayed in the ladder diagram windows, which is very helpful for understanding the operation of ladder programs.
- Component and register comments can be input through our software and can also be established using editing
software that the user has learned to use, and then subsequently using the import function to import it into our software. There is also an export function that allows the user to convert the comments of project components and registers into text files which are compatible with other applications software such as Excel, etc.

- We provide the following report document printing features
  - Ladder Program Printing:
    The user can select the range of program and comments that they wish to print and output the ladder diagram program from a printer.
  - Using component cross reporting:
    The user can print out the location of all components and function instructions used in the program.

1.3 Introduction to the operation desktop

The functions toolbar is the collection of functions included in the applications software, presented in different categories. When the user selects any of the categories in the above functions toolbar, a list of additional selectable functions will be displayed for the user to select.
In the process of the design of a project, it is often convenient to provide a toolbar with the most commonly used functions included in it for the user to directly select, which can prove to be much faster and more convenient than having to find the function through the functions toolbar.

We provide a component tray which allows the user to easily select the components and command functions that they need to use without having to search for what they want through the functions toolbar, which is faster and more convenient.

The status bar displays information on the status of the current application, such as whether the application is connected, whether it is in execution or has been disconnected, and the current location of the cursor, etc., allowing the user to know the status of the current application at all times.

1.4 How the Manuals is Arranged

- A cursor-selected function is expressed with its function name inside the brackets, and the order of execution procedures are expressed using arrows, for example: [File] \rightarrow [New Project].
- Windows that appear after a functional item has been executed are also expressed in brackets, for example: [On-Line] window.
- The finish buttons that can be selected in dialog windows are expressed using quotation marks, for example: the "OK" button.
- The field names that appear in dialog windows are expressed in brackets, while input text is expressed in quotation marks, for example: input "Test example" in the [Project Name] field.
Chapter 2 Operation Example

To give new users a clear and basic understanding of our software, this manual uses examples to introduce the basic functions that are used in the development process.

2.1 Description of Example Program

This example will demonstrate how to build a marquee control program in a WSZ-Controller, and also test and modify it, finally producing a cascaded program table. In this example, the output points are Y0~Y7. Y0 is the first to light up, followed by Y1 one second later, followed by Y2 one second later, and so on … After Y0~Y7 have all lit up, they will all go out for one second, and then repeat the same sequence all over again. The signals and comments that will be used in this example are presented in the table below.

<table>
<thead>
<tr>
<th>Number</th>
<th>Comment</th>
<th>Number</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>M0</td>
<td>Internal light number 1</td>
<td>Y0</td>
<td>Light number 1</td>
</tr>
<tr>
<td>M1</td>
<td>Internal light number 2</td>
<td>Y1</td>
<td>Light number 2</td>
</tr>
<tr>
<td>M2</td>
<td>Internal light number 3</td>
<td>Y2</td>
<td>Light number 3</td>
</tr>
<tr>
<td>M3</td>
<td>Internal light number 4</td>
<td>Y3</td>
<td>Light number 4</td>
</tr>
<tr>
<td>M4</td>
<td>Internal light number 5</td>
<td>Y4</td>
<td>Light number 5</td>
</tr>
<tr>
<td>M5</td>
<td>Internal light number 6</td>
<td>Y5</td>
<td>Light number 6</td>
</tr>
<tr>
<td>M6</td>
<td>Internal light number 7</td>
<td>Y6</td>
<td>Light number 7</td>
</tr>
<tr>
<td>M7</td>
<td>Internal light number 8</td>
<td>Y7</td>
<td>Light number 8</td>
</tr>
<tr>
<td>M8</td>
<td>Reset Signal</td>
<td>M1924</td>
<td>First scan</td>
</tr>
<tr>
<td>C0</td>
<td>Number of illuminated lights</td>
<td>T0</td>
<td>One second timer</td>
</tr>
</tbody>
</table>

Below is the actual ladder diagram program:
Below is the description of the development process presented in sequential sections.

2.2 Create a Project

Step 1: Execute the “WProlad for WSZ.exe” program.

Step 2: Select [File] → [New Project] from the function toolbar using your mouse, or press “Ctrl” + “N” on your keyboard, and the [New Project] window will appear, as is shown below:

Step 3: Enter “Test example” into the [Project Name] field.

Step 4: Click on the Edit button to enter the Controller model type selection screen.

Step 5: Select the corresponding model type according to the actual testing machine.
Step 6: Click the button, and the following screen will appear:

![Image of a software interface for inputting and editing ladder diagrams]

**2.3 Input and Edit the Example Program**

**2.3.1 Using Your Mouse to Input and Edit the Example Program**

Step 1: Now you can begin to input the ladder diagram program, first move your cursor to the upper left hand corner of the ladder diagram window and click on it, you should then see a flashing blue square at that same location.

Step 2: Move your cursor to where the component tray is, there should be an icon that looks like the following:

Step 3: Left click on the button and a B normal close contact cursor should appear, move this cursor to the location of the blue square and perform a left click. The following dialog window should appear:

![Image of a dialog window for element editing]

Step 4: Input “T0” and then press “Enter” to input T0 with a normal close contact.

Step 5: move your cursor to the button in the component tray and click on it, now a cursor in the shape of a T should appear. Left click on your mouse and the following dialog box window should appear.
Step 6: After you input “0”, use your mouse or the “Down” arrow key to move the cursor to the [PV] field and input “100” and then press “Enter” or click on the “OK” button using your mouse, now you have completed the input of the T0 timer function.

Step 7: Now input the T0 normal open contact (\(\text{T} \text{ (a)}\)) using the same method as the T0 normal close contact (\(\text{T} \text{ (b)}\)), except you click the function toolbar icon \(\text{F} \text{ (b)}\).

Step 8: After inputting the T0 normal open contact you should then input SHFL (Fun51), use your mouse to click on \(\text{F} \text{ (b)}\), then you should see a cursor in the shape of an F, move this cursor behind the T0 normal open contact and click it, then you should see the following window appear:

Input “SHFL” or function code “51” in the Function Name field, if you are not familiar with function names or function codes, you can also move your cursor to the [Class] field and click on “Shift/Rotate”, and all of the instructions related to this category will be listed, after you select “SHFL”, it will appear in the [Function Name] field, now if you press the “Enter” key or click on the “OK” button, the following window will appear:
Input “WM0” and “1” into the [D] and [N] fields, respectively, because most function block instructions have flexible pulse trigger and 32 bit operand can now be selected using a mouse or a keyboard. If you use your keyboard, use the “Alt” + “D” combination for [32 bits]; use the “Alt” + “P” combination to control the [Pulse], the [Pulse] function must be selected for this example.

Step 9: Move your mouse cursor to the in the component tray and click on it, a cursor with a horizontal short circuit icon should appear, move it at specified location and continue to fill in the horizontal short contact.

Step 10: We are now intentionally skipping the MOV instruction network, and we will revisit the following portion later on.

2.3.2 Input and Edit the Example Program Using Your Keyboard

Below is a description of how to edit application program by using a keyboard:

Positioning and Control of the Cursor -
Moving the cursor up, down, left, and right – The four arrow keys (↑ ↓ ← →)
Move to top – Ctrl + Home
Move to bottom – Ctrl + End
Move to the left-most position – Home
Move to the right-most position – End
Move up one page – Page Up
Move down one page – Page Down
When inputting various contact components using a keyboard, different letters of the alphabet are used to represent different types of components.
Normal close contact: B
Transition up contact: U
Transition down contact: D
Coil: O
Inverting coil: Q
Set coil: E
Reset coil: R
Invert the node status: I
Transition up of node status: P
Transition down of node status: N
Horizontal short: H
Vertical short: V

During input, first move your cursor to the location where you wish to make the input and then enter the component and reference number, the order of input is irrelevant, you can enter the component first or the reference number first, for example, an “AX1” or a “X1A” could be entered for a normal open contact whose reference number is X1. If only the reference number is entered, then the component of the previous operation will be assumed and used, if you simultaneously press “SHIFT” when you are entering the component, then you will enter a component with an unspecified reference number, in this case you can specify the reference number later.

Continuing the introduction of operation procedures of Section 2.3.1 Step 10:

Step 11: Press the “Esc” key, and the icon that was previously by the cursor will disappear, then move the cursor to the network labeled N002 and click on the location of the first component.

Step 12: Enter “T” using your keyboard, and the following window will be displayed, then key in “0” and press “Enter”.

The input of application functions can be divided into two categories: the first is the category of frequently used functions, such as timing, counting, set, and reset; the rest are categorized as general functions.

Input of frequently used functions:
The same contact components are represented using the same letters, what’s different is the “Shift” key should be pressed simultaneously:
1. Timer function: Shift + T
2. Counter function: Shift + C
3. Set function: Shift + S
4. Reset function: Shift + R

Inputting general functions:
First enter “F”, and the application function window should appear, and then use the mouse inputting method previously
Step 13: Enter the counter function, enter “Shift” + “C”, the following window will appear, input [C] and [PV] using the same method as described in the above timer description.

Step 14: Use the “B” and “H” keys on your keyboard to sequentially enter the rest of the N002 network.

Step 15: Sequentially enter “AM0” + “Enter” and “OY0” + “Enter”, enter network N003.

Step 16: Now enter the network N004 by using the Copy function, move the cursor to the location of the M0 contact A component, press and hold the left button on your mouse and select the entire N003 network, when the entire N003 network has been selected, enter “Ctrl” + “C”, and then move the cursor to network N004 and enter “Ctrl” + ”V”, now the entire content of network N003 will appear in network N004.

Step 17: Use the above described method to select networks N003 and N004 and copy them to networks N005 and N006.

Step 18: Use the above method to select networks N003~N006 and copy them to networks N007~N010.

Step 19: Now we will edit networks N004~N010; first move the cursor to the contact A of network N004, directly input “M1” + “Enter”, then use the down arrow to move the cursor to contact A of network N005 and repeat the above steps until the contact A of N010 has been changed to M7. Now move the cursor to the coil of network N004, and use the same method as above to edit the coils of N004~N010.

Step 20: Now let's go back to the network that we previously intentionally left out and input it, first move your cursor to network N002 and right click your mouse, a popup menu should appear, select [Insert Network] → [Before This Network]; or press the “Shift” + “Ins” hotkey, and an empty N002 network will be inserted.

Step 21: Complete network N002 using the above method.

2.4 Annotating the Example Program

Step 1: Select [Project] → [Comments] → [Element Comment] in the functions toolbar; or select the from the expanded menu; or click on the icon in the toolbar, and the following window will appear:
Click the Used button \(\Rightarrow\), and then respectively enter the example comments, as shown below:

Click the Used button \(\Rightarrow\), and then respectively enter the example comments, as shown below:
Fill in the comments using this window respectively according to the previous definitions and descriptions in the fields of the tables. The [Description] field was not used in this example, and more detailed component descriptions may be entered into this field in actual applications.

Step 2: Now we will proceed with [Network Comment], use your mouse to move the cursor to the network that you wish to annotate, right click on the mouse to call out the popup function menu, and then click on [Network Comment], and then a window for entering network comments will appear. Once you have finished entering the comments, they will immediately appear above the commented network.
Step 3: Now we will proceed with [Program Unit Comment], use your mouse to move the cursor inside the program unit that you wish to annotate, right click on your mouse to bring out the popup function menu and then select [Program Unit Comment]; a window will appear for you to input through. Once you have finished inputting the program unit comments, they will immediately appear above the annotated program unit.

Step 4: Save the previous input content to project files. Use the [File] → [Save] in the function toolbar; or press “Ctrl” + “S”. Because this is the first time you have saved a file, a [Save As] dialog box will appear, press “Enter” once you have input the file name and you are finished.

※ Please refer to Chapter 6 [Comment Information] for detailed operation procedures.
2.5 Testing and Debugging

Step 1: First save the previously entered program code to the Controller, select [File] → [Save As] → [To PLC] from the function toolbar and [PLC] → [On-Line] dialog box will appear, as shown below:

Now we can select a previous connection setting from the [Connection Name] and press "OK" to proceed with connecting to the Controller and bring out the [Data Receiving] window; if the connection is successful a [PLC Status] window will appear. If there is no applicable connection setting present, then you can connect through the "Edit" or "Add" processes. If the connections port does not correspond with the actual operations, you can select "Edit" and make modifications.

Step 2: After the previous step is completed, the content in the Controller will be the same as that in the project file, so that now you can take advantage of the [PLC] → [Run PLC] in the function toolbar; or enter the hotkey "F9" to give a command to the Controller to execute the program. You can also select [PLC] → [Stop PLC] in the function toolbar; or enter the "Ctrl" + "F9" hotkey to give a command to the Controller to stop execution of the program.
Step 3: When the Controller executes, the cascaded program window will be under the following condition:

All components that are represented with solid line boxes are connected and in an active state, and we can go and control the display of the ladder diagram program, making it possible for the program comments and register values to also be displayed on screen.

You can choose whether or not to display the different categories of information by selecting or unselecting the following items in the ladder diagram window:

- Display program unit comments
- Display network comments
- Display component comments
- Display register comments
- Display font sizes

The more information you decide to display, the richer in information your screen will be, but the less program code you will be able to view in each screen because the additional information is taking up so much room.

To select which items to display, you can click on [View] in the function toolbar and a dropdown menu will appear; the above listed items will be listed in the dropdown menu, and you will be able to select them by checking their corresponding boxes. Items that have already been selected will show a check mark on the left side, if you click on it again then the check mark will disappear and the item will be unselected, the illustration below shows the effect of selecting [Element Comment] and [Register Content]:

2-12
Step 4: Coil enable/disable control, move your cursor to the coil location and right click on your mouse, a menu that looks like the one on the right will appear, using the [Disable] function, you can free the component from the control of the program. For example, when Y0 has been disabled, its state will not be affected by the state of M0, and now you can use [ON] and [OFF] to control its status, disabled components are displayed differently, the following are display symbols for [Disable] components:

![Display Symbols]

Step 5: Use the [Status Page] for testing, first open an empty status monitoring page by doing the following: Select [Project] → [Status Page] → [New Page] from the function toolbar; or use your mouse to double-click on the Status Page icon in the project window; or use your mouse to select the icon in the function toolbar and then select to open a new monitoring page.

Once you have completed the above procedures, a dialog box will appear, please enter “StatusPage0” in the [Status Page Name] field, then press “OK” and the following window will appear:
Now move your cursor to the first blank field in the [Ref. No.] field on the far left and input “Y0–Y7” and then press “OK”, then move the cursor to the second reference number column and input “M0–M8” and then press “OK”, finally, move the cursor to the third reference number column and input “C0” and press “OK”, “T0” and press “OK”, “R0” and then press “OK”.

You will then see on the screen the reference numbers of Y0–Y7 and M0–M8, their respective enable/disable statuses and ON/OFF statuses, along with the status and values of timer T0 and counter C0. If you wish to enable or disable a node or coil, simply move your cursor to the corresponding status field and double-click, then the enable/disable option will appear. If you wish to set their values, you can move your cursor to the corresponding data field and enter 0 or 1, or double-click your left mouse button to bring up the value input window.

The display format for registers can be controlled using the [Status] field. There are currently six distinct display formats: base 10, base 10 positive numbers, base 2, base 16, floating, and strings, etc. To use them, double-click your left mouse button on the status field. The [Ref. No.] field can be displayed using component reference number or component comment; this can be done by bringing out the popup menu by right-clicking in the status monitoring page and selecting [View Element Comment].

### 2.6 Printing the Example Program

Step 1: Use your mouse to select [File] → [Print Content Setup] in the function toolbar; or press “Ctrl” + “P”, and the [Print] window will appear:

![Print window](image)

**[Edit Network] bookmark:** lists all program units in the project in the [Program Unit] field. You can use this field to select one or more program units that you wish to print, and add them to the [Print Items] field on the left; or you can select [Font]; and the [Preview] button allows you to preview the print results.

**[Comment / Description] bookmark:** all comments options for the project will be listed in the [Data Range] field. You can use this field to select one or more comment items that you wish to print, and add them to the [Print Items] field on the left; or you can select [Font]; and the [Preview] button allows you to preview the print results.
[Table] bookmark: lists all the table items in the project in the [Table List] field. You can use this field to select one or more table items that you wish to print, and add them to the [Print Items] field on the left; or you can select [Font]; and the [Preview] button allows you to preview the print results.

[Status Page] bookmark: all monitoring page items for the project are listed in the [Status Page List] field. You can use this field to select one or more monitoring pages that you wish to print, and add them to the [Print Items] field on the left; or you can select [Font]; and the [Preview] button allows you to preview the print results.

[System / Other] bookmark: project information items from the project will be listed in the [Other Item] field. You can use this field to select one or more project information items that you wish to print, and add them to the [Print Items] field on the left; or you can select [Font]; and the [Preview] button allows you to preview the print results.

[Format Setup] bookmark: can set page start/end and margin settings; and the [Preview] button lets you preview your print results. After you have finished entering the data, simply press “Print” and the printing will begin.

Please refer to Chapter 12 [Tabular Output] for detailed operation procedures.
Chapter 3 Project (File) Management

WinProladder is a project oriented programming software, presenting the content of your application program development visually using a ladder diagram display method. As shown in the illustration below, this allows the user’s work status to be viewed in a clear and intuitive fashion. This style of presentation allows program development and maintenance to be conducted in a very intuitive style and is also convenient for file management.

3.1 Establish New Project

From the functions toolbar, select [File] → [New Project] using your mouse, or press “Ctrl” + “N” and the following [Project Information] window will appear as shown below:

1. [Project Name]: Please input the name for this project for the convenience of subsequent file management.
2. [Model Name]: Select the correct model type according to the actual operation machine in the dropdown menu; the program will automatically display the specification description of the particular model type that was selected.
3. [Description]: Descriptive text for this project can be printed out.
4. [Calendar]: If the Controller has been built in the calendar, the RTC will always be able to provide the correct time and
date, regardless of whether or not the Controller is being supplied power. The time and date information provided includes week, year, month, day, hour, minute, and seconds, a total of 7 pieces of information. With the installed calendar and clock feature, users can control their systems 24 hours-a-day all year long, allowing your automatic control system to work in accordance with your daily habits and routines, not only increasing the level of automated control, but also boosting efficiency. The application of this field depends on whether this equipment exists on the Controller.

The window below will appear after you press “OK”, which means that you have successfully opened a new project. You can begin setting the various settings for your project and engage in ladder diagram program design (Described in Section 4). Remember to save your work when finished.

3.2 Open File

There are two ways to open a file: opening a project and connecting to Controller, which are respectively described below.

3.2.1 Offline Operation

Select [File] → [Open] → [Open] from the functions toolbar, or click the icon in the toolbar and select [Open] from the dropdown menu, or press “Ctrl” + “O”, and an “Open File” dialog window will appear:
And then select the file that you wish to open and press "Open" button.

Or you can quickly open the file that you previously opened by selecting one of the four latest files that you had opened provided in WinProladder Select [File] → [Open] → from the functions toolbar using your mouse, as shown in the illustration below:

Select the project name that you wish to open. The above operations will open the selected file and display it in the ladder diagram window, as shown below:

When a file is opened under off line operational conditions, all modifications can be saved through the [Save] operations described in section 3.3, or can also be saved by performing the [Save As] → [To PLC] procedures described in section 3.4.2, which reconnects the currently opened project contents with the Controller and saves it to the Controller.
3.2.2 Connection

Select [File] → [Open] → [Connect to PLC] from the functions toolbar using your mouse, or click the toolbar dropdown icon, and select [Connect to PLC], or press "Ctrl" + "L", and the confirmation window for whether to connect and open the corresponding project will appear.

1. Click the "Yes" button: which will open the project file and connect to the Controller. ( The contents of this project must be exactly the same as the content of the Controller program to be connected with, or else the connection cannot be made. )

The window for the corresponding project will open, select the project file name that you wish to open, and press "Open" button, and then you should see the content of the project program code, and the Controller connection window will also appear:

(Please refer to section 9.1 Connecting to the Controller, for instructions on setting the connection name)

When the Controller connection dialog window appears, select the desired connection file name, and press "OK" button,
and the Controller connection operation will proceed:

(After the connection has been made, information regarding this connection will be displayed)

(Press the "OK" button, and the Controller connection process will be completed)

Now, any modifications made to the project content of the opened project will be synchronously made to the Controller side as well, therefore there will be no need to perform the save to Controller operations described in Section 3.4.2. All you have to do is execute the Save Project operation described in Section 3.3 and save modifications to the storage disk; the project content on the storage disk will be exactly the same as the content on the Controller.

2. If you select “No” button: the corresponding project files will not be opened, and the connection to Controller dialog window will be displayed:

(Please refer to Section 9.1 Controller Connection for the setting of connection names)

After the Controller connection dialog box appears, select the connection name and the connection process will begin:
The project content now displayed will be the content in the Controller, so if you make any modifications, the content in the Controller will also be modified. Therefore, you may want to use the [Save] operation described in Section 3.3 to call out the Save As New File dialog box, and save the Controller contents to a storage disk.

3.3 Save Project

Select [File] → [Save] from the function toolbar using your mouse, or click the icon in the toolbar, or press “Ctrl” + “S” to save the project, which will save the project to your storage disk. This function can be used to save the modified project files to your storage disk.

3.4 Save As

When the content of the opened project has been modified, the modified content can be saved to a new file on the storage disk with a different file name through the steps described in section 3.4.1; and when opening a previous file by executing 3.2.1, the modified project can also be saved to the Controller by using the operations described in Section 3.4.2.
3.4.1 Save to Storage Disk

Select [File] → [Save As] → [Project File] from the function toolbar using your mouse. A save as dialog box will appear, as shown below:

(Enter the new file name and press “Save” button and the save as new file operation will be completed)

3.4.2 Save to Controller

When the content of a project has been modified, the modified project content can be saved to the storage disk under a different project name using the operations described in Section 3.4.1; when executing 3.2.1 to open a previously saved file, modified project content can be saved to the Controller using the operations described in Section 3.4.2.
Chapter 4 Program Input and Editing

We use a Windows operating system, and everything is designed in accordance with the Windows environment and operation style. This makes our software very easy to learn and use, and all users, from beginners to the very experienced, will all be able to operate our software with absolute efficiency. We also provide special hotkeys and mouse that are specifically designed to fit the particular characteristics of your office or working environment, making it easy for the user in all conditions and environments to efficiently input and test programs. Our flexible ladder diagram program editing feature supports high-efficiency operations such as network insertion, copying, pasting, and deleting, substantially speeding up the programming process. The following is a detailed description of each feature.

4.1 On-line and Off-line Editing

If you connect upon opening a new project (refer to Section 3.2.2), then you can use the on-line program editing function, and you can immediately execute the program after you have finished editing and do not need to re-download, substantially shortening the time needed for development and modification. On the other hand, if you open the project off-line (refer to Section 3.2.1), then you are using off line program editing, and you will have to save to the Controller after you are done editing (refer to Section 3.4.2). It also supports run time on-line editing feature for allowed non-stop application modification.

4.2 Input via Mouse and Hot Key Operation

When inputting program in the ladder diagram window area, you can use your mouse to select component types from the component tray, or you can input via hot keys, depending on the preference of the user.

4.2.1 Inputting Via Mouse

When editing, you can use your mouse to click on the component tray, and then select contact A:

![Input via Mouse Diagram](image)

Click on the position on which you would like to input the component in the ladder diagram window:
Then you will see a dialog box prompting you to enter the reference number for contact A, enter X0, and now you have completed the input of a contact component in the ladder diagram window:

![Diagram of ladder diagram component]

### 4.2.2 Input via Hot Keys

Place the cursor at the location where you wish to input the component in the ladder diagram input window, press the hot key “A”, and the dialog box prompting you to enter the reference number of contact A will appear. Enter X0, and now you have completed the inputting of a contact A component in the ladder diagram window. Or, you can directly input “AX0” or “X0A”, which are also fast inputting methods. Or you can press the “Shift” + “A” Hot key, and then the following diagram will immediately appear in the ladder diagram program location:

![Diagram of input via hot keys]

Double-click, and follow the above described procedures.

WinProladder provides convenient hotkey operation features; please refer to Section 17.1[Hotkey Table].

### 4.3 Main Program and Sub Program Unit Operation

In the WinProladder ladder diagram programming window, there are two areas- the main program area and the sub program area- which makes the programming process even more structured. The operation procedures in the two areas are identical. The following are instructions for performing operations with program units.

#### 4.3.1 Establish a New Program Unit

You can devise a plan for categorizing your programming process into different programming segments, which will provide an additional degree of structure. Therefore, using the feature for establishing a new program unit, you can make your program even more easily understandable.

We can select [Project] → [Main Program] → [New Unit] in the function toolbar using our mouse, or select [New Unit] in the dropdown menu after clicking on the icon in the toolbar:
Or, in the project window, go to [Test example] → [Ladder Diagram] → [Main Program] right-click → [New Main-Program Unit]:

After you select [New Main-Program Unit], a dialog box prompting you to enter the program unit name will appear. As an example, you may enter something like “Channel Control”:

After you press “OK”, you will find that a [Channel Control] program unit has been added to the [Main Program] in your project window:

The procedures for the sub program area [New Program Unit] operation are the same as for the main program area; all you need to do is select the sub program operation.
4.3.2 Program Unit Deletion

When an established program unit is no longer needed, you can use the program unit deletion function to delete it. We can use our mouse to select [Project] → [Main Program] → [Delete Unit] in the function toolbar; or by clicking the icon in the toolbar and selecting [Delete Unit]:

Or select [Test example] → [Ladder Diagram] → [Main Program] right-click [Delete Main-Program Unit] from the project window:

After you select [Delete Main-Program Unit], a delete program unit dialog box will appear. Select "Channel Control":

After pressing "OK", you will be prompted again to confirm whether or not to delete the selected program unit:
Click "Yes" and then you will find that the previous [Channel Control] program unit in the [Main Program] of the project window has been deleted:

The procedure for [Delete Program Unit] for the sub program area is the same as for the main program area, with the exception of having to select the sub program operation.

### 4.3.3 Adjust the Order of the Program Units

If, after you have established many program units, you wish to adjust the order in which they reside in execution sequence, you can use the program unit order adjustment feature. We can use our mouse to select [Project] ➔ [Main Program] ➔ [Relocate Unit] from the function toolbar, or select the [Relocate Unit] option in the dropdown menu by clicking on the icon in the toolbar:

Or select [Test example] ➔ [Ladder Diagram] ➔ [Main Program Unit] right-click [Relocate Main-Program Unit] from the project window:
After selecting [Relocate Main-Program Unit], a dialog box for adjusting the order of program units will appear. Select “Channel Control”, and if you wish to position it after “Change Control”, Press “Move Down”:

Then you will find that “Channel Control” has already been positioned behind “Change Control”:

After you press “OK”, the order of the program units in the project window will also be different:

The [Relocate Program Unit] for the sub program area has the same procedures as that of the main program area, except
you choose the sub program operation. Please notice that the program unit location of sub program area doesn’t matter with the execution sequence.

**4.3.4 Modify Program Unit Name**

After the name of a program unit has been established, it can subsequently be modified by using your mouse to select [Test example] → [Ladder Diagram] → [Main Program] → [Channel Control] right-click [Rename] from the project window:

![Select Rename](image)

After choosing [Rename], you can change the name of this program unit to [Control Channel]:

![Control Channel](image)

When you have completed the name modification, you will find that the name of the program unit in the project window and the page name in the cascaded graphical program window have changed.

**4.3.5 Enter Program Unit Comments**

When there are a lot of program units, we will need to add comments to the program units, so that future lookups and modifications can be performed more easily.

**4.3.5.1 How to Input Comments from the Dedicated Comments Area**

Use your mouse to select [Project] → [Comment] → [Program Unit Comment] from the function toolbar, or select the ![Icon](image) icon from the toolbar; or go to [Test example] → [Comment] → [Program Unit Comment] from the project window and double-click on [Program Unit Comment] input area will appear:

![Comment Input Area](image)
You will see a list of all program unit names. Double-click on the empty comments area on the right-hand side of the “Coin Insertion Count” program unit:

Enter the comment “Count the Accumulated Number of Coin Insertions”, press “OK”, and the entered comment will first appear at the [Coin Insertion Count] top of the ladder diagram program area of this page, as shown in the following illustration. If you confirm it to be correct then you can press “OK” in the program unit comments dialog box. Now you have completed the comment input for the [Coin Insertion Counting Program].

4.3.5.2 Method for Selecting a Single Program Unit and Directly Inputting a Comment

In the ladder diagram program area [Coin Insertion Count], you can also choose to right-click on your mouse, and then select [Program Unit Comment] in the functions menu that appears:
Or, from the function toolbar [Edit] → [Program Unit Comment]; then a program unit comments input area representing [Coin Insertion Counting] Program Unit will appear:

After pressing “OK” you will have completed the comments input for the program unit:
### 4.4 Contact Components Operations

In the function toolbar [Ladder] → A Contact to vertical component item, and the various contact components listed in the component tray, as shown in the below illustration:

![Ladder diagram with A Contact]

By simply selecting the contact component you wish to input, it will be expressed in the ladder diagram program area. The following are the procedures for doing this.

### 4.4.1 Input Contact Component

Use your mouse to select [Ladder] → [A Contact]; or select the icon which represents the A Contact in the components tray; or right-click on your mouse in the ladder diagram program area and the following popup functions menu will appear (as shown below), then select [Contact] → [A Contact]:

![Popup functions menu]

Then click on the location in the ladder diagram program area that you wish to perform the input at, and the reference number input dialog box will appear:

![Reference number input dialog box]

Enter “X0” and then press “ENTER”, and the following screen will appear:

![Reference number input]

Or place the cursor at the location in the ladder diagram program area in which you would like to perform the input and directly input “AX0” or “X0A”, and the above screen will also appear; or press “Shift” + “A”, and only the A contact component will appear in the ladder diagram program area, and there will be no need to input the reference number for the component, as shown below:
4.4.2 Change the Type or Reference Number of the Contact Component

When you need to change the component type of a previously inputted contact component, first select the contact type that you wish to change to (its selection method is the same as that described in Section 4.4.1), then select it from the component tray, and click the contact component that you wish to make the modification for in the ladder diagram program area, and then the dialog box for inputting the contact component and reference number will appear. Or you could place the cursor on the component which you wish to modify, and directly enter “B”, representing contact B, and the dialog box for inputting the reference number for the contact B component will also appear. If you only wish to modify the component reference number, use your cursor to select the component that you wish to modify in the program area, and directly enter the new reference number or press “SPACE” to bring up the editing window for entering the new reference number, as shown below:

You can re-enter the reference number for contact B in the dialog box, for example X1, and the previous X0 for contact A will be changed to X1 of contact B.

4.4.3 Deleting Contact Components

You can select the icon from the component tray, or right-click your mouse in the ladder diagram program area and select [Delete] from the popup menu, and the cursor will represent the delete operation; or directly click on the X1 component at contact B, and then press the “Delete” key, this will also delete the component:
4.5 Usage of Function Block Instructions

WinProladder also provides a convenient set of function block instructions. We can go to the function toolbar [Ladder] → [Setting] [Reset] [Timer] [Counter] or [Function], and select any of the above functions that are needed; or we can also click on the following icon in the component tray, which also represents the function options:

![Function Block Icons]

4.5.1 Input Function Block Instructions

For example, if you wish to set a timer with fixed time duration, you will need to control when the timer starts, when it stops, and the accumulative value that it uses for its timing purposes etc., which are all described below.

Between the X1 contact A and Y0 output, to set a fixed period timer, you can perform the setting procedures by entering timer function. But it is necessary to make three columns of left of coil Y0 a blank to place the timer:

You can select [Ladder] → [Timer] from the function toolbar; or you can select the timer icon from the component tray; or use the hotkey “Shift” + “T”; Now the cursor has been set to the timer function, click once between X1 and Y0 in the ladder diagram program area, and the [Timer] function settings dialog box will appear:

![Timer Function Settings]

Enter “T0” into the [T] field; enter “1000” into the [PV] field, and you have completed the settings for a set period timer:
4.5.2 Editing Function Block Instruction

When you wish to modify existing function block instruction, if the cursor is not in the “Selection Cursor” state, then you should first set the cursor to the “Selection Cursor” state. You can select the icon from the component tray, or right-click on your mouse in the ladder diagram program area and select “Select” from the popup menu, and then double-click on the existing function block that you wish to modify, and the editing window will appear:

Or select the function block that you wish to modify with the cursor, press “SPACE” and the dialog box for entering the new reference number will appear.

And now you can proceed with the editing of the function block. For detailed descriptions of the types and usage methods of the function blocks, please refer to WSZ Programmable Controller User Manual I & II.

4.5.3 Delete Function Block Instruction

Function block components are deleted in the same way contact components were deleted in Section 4.4.3.

4.6 Usage of Step Ladder Instructions

To give your program a higher degree of readability, to facilitate easy maintenance and updating, and to substantially increase the quality and reliability of your software, we place particular emphasis on the sequential control of mechanical operations, combining a wide range of existing ladder diagram programming languages with the support of step ladder instructions.

Select [Ladder] → [Function] from the function toolbar; or click on the icon in the component tray; or right-click your mouse in the ladder diagram program area and select [Function] → [Function] from the popup menu, then click on the location in the ladder diagram program area where you wish to input the step ladder instructions, and all function categories will appear, then select [SFC] under the category item, and then four step ladder instructions, which are [STP] [FROM] [TO] and [STPEND] respectively, will appear at the right hand side of the function name, as shown in the illustration below:
The procedures are described below.

### 4.6.1 Input Step Ladder Stages (STP Instruction)

To set an initial step ladder stage S0 to serve as the initial stage after a system start, follow the instruction described below:

Select the contact A component in the component tray, click once on the ladder diagram network and input “M1924” into the reference number input field:

Click on the icon in the component tray, click once behind the “M1924” contact instruction, and then the [Function Lookup] window should appear, select “SFC” under the [Class] option, select “TO” for the [Name], press the “OK” button, and the following window will appear:

Enter “S0”, press the “OK” button, repeats the “SFC”, this time choose “STP” for [Name] or press shortcut keys “?” And the following illustration will appear:
Enter “S0”, press the “OK” button, and you have completed the setting of the S0 initial step ladder stage to serve as the initial stage after each system starts.

You can also add step shifting criteria to the initial step ladder stage. First select [Vertical Short] component from the component tray using your mouse, then click on "STPI S0"; or place the cursor on top of "STPI S0", and press the “V” hotkey.

After the branching line appears, add shift conditions, for example, we can add two shifting conditions "X0" and "Y0". and then add the step that you wish to shift to when the shifting conditions are met, in our example, when the "X0" and "Y0" conditions are met (ON), we shift the step to "S21". Bring out the [SFC] categories, select [TO] for the function name; or press the “>” hotkey, and after the dialog box appears, enter "S21", and the following example is completed:
4.6.2 Input Convergence (From Instruction)

This instruction describes the source step from which the current stage was entered from, and also requires the meeting of conditions from stage Sxxx to continue to the next step ladder stage.

For detailed examples and an explanation of underlying principles, please refer to Chapter 8 [Step Instruction Description] of User Manual I. Here, we only illustrate the steps and procedures for using the WinProladder ladder diagram program as an example:

4.6.2.1 Selective Convergence

If we wish to produce the above results, we could follow the instructions below:

We first bring out the [SFC] category according to the procedures described in Section 4.6, select [FROM] for the function name, press “OK”, or place the cursor in the program area, and press the “<” hotkey, and the following window will appear:

Enter “S21”, press the “OK” button, move your cursor to the [A Contact] component in the component tray and click on behind it, and click the back of “FROM”, and the following window will appear:

Input “X5”, and press “ENTER”, use the function block again, bring [FROM] for the function name, press “OK”; or press the “<” hotkey, and the following window will appear:

Enter “S22”, press the “OK” button, move your cursor to the [A Contact] component in the component tray and click on behind it, and click the back of “FROM”, and the following window will appear:
Enter “X6”, press “ENTER”, and then move the cursor to the component tray and select component, and then single-click behind the X5 contact; or place the cursor on X5 and press the “V” hotkey, and a vertical line will appear, as shown in the following illustration:

Now enter “X7”, as shown in the following illustration:

Use the function block again, bring out the [SFC] category, choose the function name [TO] and press “OK”, or place the cursor in the program area, and press the “>” hotkey, and the following window will also appear:

Enter “S23”, press “OK”, and you have completed the procedures for this selective convergence example.

**4.6.2.2 Simultaneous Convergence**

When we wish to produce the above results, we could follow the following procedures:

We first refer to the procedures in Section 4.6 and bring out the [SFC] category, choose the function [FROM], press “OK”, or place the cursor in the program area, and press the “<” hotkey, and the following window will also appear:
Enter "S21", press "OK", bring out the [SFC] category again, choose [FROM] for the function name, press "OK", or place the cursor in the program area, and press the "<" hotkey, and the following window will also appear:

Enter "S22", press "OK", move the cursor over to the component tray and select [Vertical Short] component, and then single-click behind ; or press the "V" hotkey, and you have completed the procedure for expressing simultaneous convergence in a ladder diagram program:

Select the [A Contact] component in the component tray using your cursor, and then single-click behind :

Enter "X3", and press “ENTER”. Use the function block again, bring up the [SFC] category, choose [TO] for the function name and press “OK”, or place the cursor in the program area, press the ">" hotkey, and the following window will also appear:
Enter "S23", press "OK", and you have completed this example for simultaneous convergence.

It should be especially noted that to complete a simultaneous convergence operation, the \[Vertical Short\] component must be adjacent to the \[FROM S21\]... if there is any space between the two, it will become a selective convergence operation, as shown in the following illustration:

```
FROM S21
\[Vertical Short\]
FROM S22
```

### 4.6.3 Input Divergence (To Instruction)

This function describes the step ladder stage to be shifted to. For detailed examples and explanations of the underlying principles, please refer to Chapter 8 [Step Instruction Description] of User Manual I, here we only describe the steps and procedures for using the WinProladder ladder diagram program with an example.

#### 4.6.3.1 Selective Divergence

When we wish to produce the above results we could follow the following procedures:

Place the cursor at the location where you wish to input in the program area, bring out the [SFC] category, select [FROM] for the function name; or press the "<" hotkey , and the following window will appear:

```
FROM S30
```

Enter "S30", press "OK", and the S30 component of the FROM function will appear in the program area. Single-click behind the contact A component, enter the reference number "X3"; or immediately input "AX3", as shown in the window below:

```
FROM S30
```

Now enter X0 right after X3:
After X0, place the cursor at the location where you wish to make the input in the program area, and then bring up the [SFC] category, choose [TO] for the function name; or press the hotkey "->", and the following window will appear:

Enter "S31", press "OK", place the cursor at the X0 location, enter "V", add a vertical line, as shown below:

Now place the cursor under X0, enter "X1" or "X1A":

After inputting component X1, bring out the [SFC] category again, choose [TO] for the function name; or press the "->" hotkey, and the following window will appear:

Enter "S32", press "OK", and you have completed this selective divergence example.
4.6.3.2 Simultaneous Divergence

If we wish to produce the above results, we could follow the following procedures:

Place the cursor in the program area and at the location where you would like to make the input, bring up the [SFC] category, choose [FROM] for the function name; or press the "<" hotkey, and the following window will appear:

Enter "S30", press "OK", and the FROM function will appear. Use the cursor to select the contact A and single-click the point right behind it, enter the reference number "X3"; or directly enter "AX3" behind it, as shown in the following window:

Place the cursor in the program area and at the location where you wish to make the input, bring out the [SFC] category again, choose [TO] for the function name; or press the "->" hotkey, and the following window will appear:

Enter "S31", press "OK", and the TO function will appear. Under the S31 location of the completed TO function, bring up the [SFC] category again, and choose [TO] for the function name; or press the "->" hotkey, and the following window will appear:
Enter “S32” and press “OK”. Select vertical line component with your mouse, and click on the icon in the program area; or press the “V” hotkey, and the following will appear:

Now you have completed an example of a simultaneous divergence operation.

4.7 Editing Mode

In the cascaded graphical program editor, we provide functions similar to the [Replace] and [Insert] modes of general word processors for your convenience, and below are their descriptions.

4.7.1 Replace Mode

When the status bar shows that the system is under [Replace] mode, the cursor display mode in the cascaded graphical program area will be as follows:

Place the cursor at the location X1, directly input “X2”, and then the following will appear:
X2 has replaced X1. This is the replacement mode of operation. If you press the “Insert” key again, you will switch back to the insertion mode.

### 4.7.2 Insertion Mode

When the cascaded graphical program is in replacement mode, press the “Insert” hotkey, and you will switch the system into insertion mode, where the status bar will display [Insert] mode, and the cursor in the program area will become square shaped, as shown in the following.

Now place the cursor on the X1 component, and directly enter “X2”, and you have inserted a reference number X2 component between X0 and X1, as shown below:
This is the insertion mode, and if you press "Insert" again you will switch to the replacement mode.

### 4.8 Changing of Components and Reference Numbers

You will often need to perform changing operations during component editing in the program area, in addition to the replacement mode described in Section 4.7.1, this can also be accomplished using the [change] function provided in the function toolbar, as described in the following:

Example: The procedures for changing X2 into X3 are described below:

First, in the program area, select the network number that the contact instruction you want to change resides in, as shown below:

Execute [Edit] → [Replace] in the function toolbar; or press the “Ctrl” + “R” hotkey, and the following changing dialog will appear:
[Find Ref] is the reference number for the component that you wish to change, in this example, it is X2.

[Length] is the total length of the component which you wish to replace, in this example, it would be 1. If you were to enter 10, it would mean that X2~X11 would be changed, and the changing also proceeded in accordance with the reference number sequence, for example, if you were to enter X0 in "Find Ref", 10 in "Length", M0 in "Replace Ref", then X0~X10 would be changed into M0~M10.

[Replace Ref] is the reference number of the component which you wish to replace.

If [Range] is the "Select", then only all X2 will be changed into X3 in the selected network.

If [Range] is the "Current Unit", then every X2 in the program unit will be changed into X3.

If [Range] is the "All", then every X2 in all units of the project will be changed into X3.

For [Options] check "Also replace the comment and descriptions", and the comments and descriptions for X2 are replaced by those for X3 as well, and after you press "OK", the total number of replacements will be displayed. In this example, we have completed the replacement of 1 reference number.

4.9 Searching for Components

Because of the structural design of the WinProladder software, there are also two ways to search for components, which are described in the following.

4.9.1 Search One at a Time in the Current Program Unit

If you want to search for an X3 component in the current program unit, please execute [Edit] → [Find…] from the function toolbar; or press the hotkey "Ctrl" + "F", and the dialog box for setting up search criteria will appear:
Enter “X3” into the reference number field, you can also check the category of the component that you wish to search for in [Type], and set the search range in [Range], and set the start point for the component search in [Starting address], and specify to either search upwards or downwards in [Direction]. Press “OK”, when the program finds the first X3, the cursor will be placed at its location; if there are other X3 components in the program unit, a dialog box asking whether or not to continue searching will appear:

When you press the “Next” button, the program will search for the next X3, until the end of the program unit. When there are no more X3 components, a dialog box saying “Search not found” will appear:

If you press the “Cancel” button, the program will not search for the next X3, and the cursor will stop on the last X3 location. If you want to continue searching for the next X3, you can press the “F3” hotkey, which stands for [Find Next]. If you continue to press “F3”, the program will continue to search for subsequent X3 components, all the way to the end of the program unit. When there are no more X3 components, you will see a “Search not found” notification dialog box.

4.9.2 Batch Searching in Projects

To perform a batch search for component X3, please execute [Edit] → [Find in Project] from the function toolbar; or press the hotkey “Ctrl” + “F3”, and the search criteria dialog box will appear:

The [Find Ref] and [Type] are set in the same way as described in Section 4.9.1.
Set [Range] to “All”, which specifies to search the entire project. If the [Range] is set to “Opened Program Unit”, then only the currently opened program units will be searched. Press “OK” and all the search results will be displayed in a new window in the program area, as shown below:

Double-click on one of the search results in the [Search Result], and the cursor will move to the selected X3:

1. Double-click.
2. Cursor will move to corresponding location.
4.10 Network Operations

Networks are an important element for the ladder diagram program area, and there are many ways to perform operations on them. The following is an introduction to methods for performing network operations.

4.10.1 Copy Single Network

Select the network that you wish to copy using your cursor, for example, network number N009, as shown below:

Then use the same copy and paste procedures as described in Section 4.10.1, and you have completed the procedures for copying a single network.

4.10.2 Copy Multiple Networks

To copy networks with adjacent numbers N000 through N002, you can select N000 through N002 via click-and-drag, or press and hold "Shift" while selecting N000 through N002, as shown below:

Then use the same copy and paste procedures as described in Section 4.10.1, and you have completed the procedures for copying multiple networks.
for copying multiple networks with adjacent numbers.

If you wish to copy networks N001 and N003, whose numbers are not adjacent to one another, first click and select network N001 with your mouse, then select networks N003 while holding down the “Ctrl” key, and you will obtain the following result:

Now you can perform the same copy and paste procedures as described in Section 4.10.1, and you will have completed the operation of copying multiple networks whose numbers are not adjacent.

**4.10.3 Copying Networks from Different Projects**

First, executing the WinProladder application software and then open the first project file; now execute the WinProladder software again, and then open the second project file, so that you now have two WinProladder application software windows opened. Select network N001 in project one, and then right-click on your mouse to bring up the popup menu and select “Copy”, or, press the hotkey “Ctrl”+“C” to copy it. Then place the cursor in Project 2 where you would like to paste it, and then right-click your mouse to bring up the popup menu and select “Paste”, or, press the hotkey “Ctrl”+“V” to paste it on. And now you have completed the procedure for copying networks between projects.

**4.10.4 Deleting Networks**

Select the number of the network that you wish to delete, and execute [Edit] → [Delete] from the function toolbar; or press the hotkey “Delete”, and a dialog box asking you whether or not to [Delete Network] will appear:

Press “Yes” button, and the network will be deleted.
4.10.5 Network Row and Column Editing

Ladder diagram program area is composed of many networks with numbers, numbering the rows and columns of a network can make your program very organized and easy to maintain. The rows and columns of a network can also provide many functions, which can help make your programming process even more convenient and fast. The following is a description of how to use these features.

4.10.5.1 Expand to 22 Columns

When there are many contact components, the original 11 columns of a network may not be enough, and you can expand the network to 22 columns. Place the cursor on the network that you wish to expand to 22 columns, execute [Edit] → [Network Edit] → [Expand to 22 Column] from the function toolbar; or right-click on your mouse to bring up the popup menu and execute [Network Edit] → [Expand to 22 Column].
**4.10.5.2 Shrink to 11 Columns**

Place the cursor on the network that you wish to shrink from 22 columns to 11 columns, execute [Edit] → [Network Edit] → [Compress to 11 Column] from the function toolbar; or right-click on your mouse to bring up the popup menu and execute [Network Edit] → [Compress to 11 Column].

**4.10.5.3 Vertical Expansion**

If you wish to increase the vertical space between upper and lower rows X1 and X3, as shown in the following illustration:

![Vertical Expansion Illustration]

Then select X3 with your cursor:

![Vertical Expansion Select X3]

Execute [Edit] → [Network Edit] → [Vertical Expand] from the function toolbar; or right-click on your mouse to bring up the popup menu and execute [Network Edit] → [Vertical Expand] and you will have completed your vertical expansion.

**4.10.5.4 Vertical Compression**

If you wish to save the vertical space between the upper row X1 and the lower row X3, as illustrated below:

![Vertical Compression Illustration]

Then use your mouse to select the blank space between X1 and X3 that you wish to compress:

![Vertical Compression Select Space]

Execute [Edit] → [Network Edit] → [Vertical Compress] from the function toolbar; or right-click on your mouse to bring up the popup menu and execute [Network Edit] → [Vertical Compress] and you will have completed the vertical compression.
4.10.5.5 Horizontal Expansion

If you wish to increase the space between X0 and X3:

![Diagram showing horizontal expansion]

Execute [Edit] \(\Rightarrow\) [Network Edit] \(\Rightarrow\) [Horizontal Expand] from the function toolbar; right-click on your mouse to bring up the popup menu and execute [Network Edit] \(\Rightarrow\) [Horizontal Expand] and you will have completed the horizontal expansion.

4.10.5.6 Horizontal Compression

If you wish to shrink the space between X0 and X3:

![Diagram showing horizontal compression]

Execute [Edit] \(\Rightarrow\) [Network Edit] \(\Rightarrow\) [Horizontal Compress] from the function toolbar; or right-click on your mouse to bring up the popup menu and execute [Network Edit] \(\Rightarrow\) [Horizontal Compress] and you will have completed the horizontal shrinkage.

4.10.6 Insert Blank Network

If you wish to insert a blank network above network number N012, you can proceed as follows:

Right-click on your mouse on any component in the N012 network in the cascaded program area and bring up the popup menu. Then execute [Insert Network] \(\Rightarrow\) [Before This Network]; or right-click on the network number N012 and bring up the popup menu. Then execute [Insert Network] \(\Rightarrow\) [Before This Network]; or press the hotkey “Shift” + “Insert”, and then network N012 will be a blank network, and the network content that was previously numbered N012 will become network N013.
4.10.7 Insert Network Comments

For example, if you wish to input comments for network N005, you could place the cursor on the number N005 or any component in it, and execute [Edit] → [Network Comment] from the function menu; or you can right-click to bring up the popup menu and execute [Network Comment], and the network comments inputting area will appear:

Enter “Annotations for Solution Network N005”, press “OK”, and you will see the comment in the row above network serial number N005:

Or you can double-click on [Test Example] → [Comments] → [Network No.] in the project window, and all the network serial numbers will appear. Find network N005 and double-click in the blank comments area, and the blank network comments input area will appear:

Enter “Annotations for Solution Network N005”, press “OK” button:
Press the “OK” button again, and you will have completed the network comments inputting procedure.

**4.10.8 Network Searching**

If you wish to search for network N002 in the [Coin Insertion Count] program unit, you can execute [Edit] → [Goto...] from the function toolbar; or press the hotkey “Ctrl”+“G”, and the following window will appear:

Select “Coin Insertion Count” in the [Program Units], and enter “2” to represent N002 in the [Network Number]. Press “OK” button, and the cursor will move to the position of the network you are looking for.
4.11 Ladder Program Syntax Check

4.11.1 Execute Syntax Check

After you have completed the input of your application program, you can run a syntax check, which will help you find errors in the program. We can execute [Tool] \(\Rightarrow\) [Syntax Check] from the function toolbar; or press the “F8” hotkey, and the statistical syntax error table will appear:

![Syntax Check dialog box](image)

After you press the “OK” button, if there are errors, the errors will be listed under the program area, and if you double-click on one of the error items, then the erroneous component segment will be displayed in the program area, as shown below:

![Program area with syntax errors highlighted](image)

1. Double-click.

2. The cursor will move to the erroneous component segment.

Please refer to User Manual I - Hardware & Basic Functions description for the syntax rules of the WSZ series Controller, and also refer to the syntax error codes table. The display segment of the error list contains two types of messages: one is the syntax inspection results error table; the other is the results for the project contact component reference number search; right-click on your mouse and three options will appear in a popup menu:

1. **Clear results for syntax check**: the execution of this item will clear error messages resulting from the [Syntax Check].

2. **Clear results for data search**: the execution of this item will clear results from the [Search in Project] command.

3. **Save Messages**: this will save the error messages from the error table in the display area to a text file.
4.11.2 Syntax Check Setting Options

In addition to the user being able to perform a syntax check at any stage of program editing, before executing (RUN), the system will also automatically perform a syntax check to ensure safety. The user can specify the items to be checked for both the user initiated syntax check and the automatic system initiated syntax check. Execute [Project] ➔ [Options] from the function toolbar; or press the "Ctrl"+"F8" hotkey, and the following screen will appear:

![Options Screen]

In this options page, the user can specify the item that they do or do not want to check, and when the conditions for stopping the check have been met (when the number of error or warning messages has reached the specified limit), the system will cease the syntax check.
Chapter 5 Table Entry and Editing

To give users a familiar interface for producing tables, communications parameters, and command table settings, the WinProladder application provides tabular entry features. The following is an introduction to the various tabular operations.

5.1 ASCII Table

For text table usage and internal representative meanings, please refer to Chapter 14 Advanced Functions in User manual II: [Application of ASCII Output Function].

5.1.1 New ASCII Table

Select [Project] → [ASCII Table] → [New ASCII Table] from the function toolbar; or select [New ASCII Table] from the dropdown menu by clicking on the icon in the toolbar; or, in the project window, right-click and select [New ASCII Table] from [Test Example] → [Table Edit] → [ASCII Table]:

And the table edit window will appear:

Input “Substrate Division Production Statistics Table” in the [Table Name] field, and define “R0” as the [Table Starting address], choose “Dynamic Allocation” for the [Table Capacity], and input any descriptive text that you would like to
specify in the [Description] field:

The text for the table that you would like to output can be input in the [ASCII Editor] field, and when you are inputting, you can preview your output in the [Output Preview] field below. Or you can click the button, and select a text file that you would like to import, cutting down on the time needed for input:

After you finish inputting, you may also click the icon and save to a new text file, so that you will be able to open and reuse the file at a later time.

When you click the icon, you will enter the same window as when you select [New Table] and enter the [Table Name] initial settings windows..., where you can perform additional renaming and description modifications. After you have finished editing the text table, press the “OK” button, and you will have completed the creation of the new text table, and you will see that a new item called [Substrate Division Production Statistics Table] has appeared in the [Project Window], as shown below:
Also, under [Project]→[ASCII Table] in the function toolbar, the new item [Substrate Division Production Statistics Table] will have also been created, as shown below:

**5.1.2 Modify ASCII Table Name**

In the project window, select the text table with the name [Basic Section Group], right-click on your mouse and select [Rename] from the popup menu that appears, and then you will be able to modify the name:
Or, you can double-click on the name of the [Basic Section Group] ASCII table, and select [Setup] in the ASCII table input window that appears, and you will also be able to modify the name.

5.1.3 Delete ASCII Table

Select [Project]→[ASCII Table]→[Delete Table] from the function toolbar, or click on the icon in the toolbar and select [Delete Table] from the dropdown menu; or, in the project window, in [Text Example]→[Table Edit]→[ASCII Table] right-click and select [Delete Table]:
And the Delete ASCII table window will appear:

Use your cursor to select the "Basic Section Group" ASCII table item, and press "OK", and you will see a deletion confirmation window:

Press "Yes", and the "Basic Section Group" item under [ASCII Table] will have disappeared.
5.2 Link Table

5.2.1 General CPU LINK Communication Table

5.2.1.1 Create a New General CPU LINK Communication Table

If you wish to create a new "General CPU LINK Communications Table", please execute [Project]→[Link Table]→[New Link Table] from the function toolbar; or click the icon in the toolbar and select [New Link Table] from the dropdown menu; or select [Test Example]→[Table Edit]→[Link Table]→[New Link Table] from the project window, as shown below:

An [Table Edit] window will appear, select "Normal Link Table" from the dropdown menu in [Table Type], input "General CPU LINK Communications Table" in [Table Name], and then set the [Table starting address] and enter the necessary descriptive text:
The [Table Capacity] allows the user to choose whether to allow the system to automatically and dynamically set the editable length and size of the table, or to manually set a fixed length range and not let the table exceed this length. For example, if the user chooses a fixed table content length of 30:

When adding a new communications item, the total length must not exceed 30.
After you have finished specifying the settings, press "OK", and you will be able to begin editing the necessary [Link Command]:

If the length of the next item will exceed 30, you will not be able to create a new communications item.

[Calculator] field: brings up the simple calculator included in Windows, as shown below:

[Setup] field: brings up the edit table window. The user can rename the editable window, or modify the initialization point, as shown below:
[Monitor] field: can randomly monitor whether communication commands are successful or not, but you must be careful of one thing: the monitor feature can only be used with the “Z” hotkey (refer to Section 5.7 for details), which calls up the table, and cannot be executed from the communication commands table in the project management window.

If you wish to create a new communication command item, first press the “Add” button, and the following window will appear:
Fill the relative master and slave communications settings, press “OK” and the newly specified data item will be created in [Normal Link Table]:

On the right side of the “Add” function button, there is also:

1. **Insert**: inserts an item between 0 and 1 of the original items list, choose item 1, and then press the “Insert” button, and the same settings screen that appears when you press the “Add” button will appear, and now you can insert a data item, as shown below:

2. **Edit**: select the item that you would like to edit and press the “Edit” button, and the same settings screen as when you press the “Add” button will appear, and you can proceed the modification of the original data settings.

3. **Delete**: select the item that you would like to delete, press the “Delete” button, and it will be deleted.

4. **Move up**: select item number 1, and press the “Move up” button, and you will move up one item number.

5. **Move down**: exactly the opposite as the move up button.

After the necessary [Link Command] have all been set, press the “OK” button, and you will have completed the creation of a [Link Table], and you will find a newly created table under the [Link Table] category in the [Project Window], as shown below:
5.2.1.2 Modify General CPU LINK Communication Table Names

Follow the procedures described in [Modify ASCII Table Name] of Section 5.1.2, or, in the table edit window, click the "Settings" button.

5.2.1.3 Delete General CPU LINK Communication Table

Follow the procedures described in [Delete ASCII Table] in Section 5.1.3.

5.2.2 High-speed CPU LINK Communication Table

5.2.2.1 Create New High-speed CPU LINK Communication Table

Follow the same procedures as in [create new general CPU LINK communication table] in Section 5.2.1. The only difference is, in the [Table Edit] window that is brought up, you must select "High Speed Link Table" from the dropdown menu in [Table Type], as shown below, the rest is exactly the same:
After you press the “OK” button, a [High Speed Link Table] window will appear, press “Add” and a [Link Command] window will appear, as shown below:

Enter “1” into the [Broadcaster Station] field, set the [Data Length] and [Data Start Address], press the “OK” button, and you have completed a high speed Link communication command, as shown below:

You can also use the “Insert” button to insert a communication command; or select the communication command that you would like to modify, and press the “Edit” button, and you will be able to modify it; press the “Delete” button and you will be able to delete the communication command. Use the “Move Up” and “Move Down” buttons to change the order and sequence of the various communication commands.

5.2.2.2 Modify the High-speed CPU LINK Communication Table Name

Follow the same procedures and in [Modify ASCII Table Name] in Section 5.1.2, or, click the “Setup” button during table editing.

5.2.2.3 Delete a High-speed CPU LINK Communication Table

Follow the same procedures as described in [Delete ASCII Table] of Section 5.1.3.
5.2.3 General Purpose LINK Table (Mode1, 2)

5.2.3.1 Create New General Purpose LINK Table (Mode1, 2)

Execute [Project]Æ[General Purpose Link Table]Æ[Add General Purpose Link Table] from the function toolbar; or, click the icon and select [New General Purpose Link Table] from the dropdown menu; or, in the project window, select [Text Example]Æ[Table Edit]Æ[General Purpose Link Table] right-click and select [Add General Purpose Link Table], as shown below:

Use the same settings as in [New ASCII Table] to specify the settings for the name and other items in [General Purpose Link Table] below:

Press the "OK" button, and you will enter the [Communication Parameter Setting] screen:
**Communication Mode**

0: only transmit messages/only receive messages.

1: receive message after transmission of message/transmit message after receiving of message.

**Start Code**: set Start code of receiving.

**End Code**: set End code of receiving.

**Command Edit**: when in the middle of editing, you can preview in the [Data Preview] section below.

**Data Preview**: you can use your mouse to drag and drop ranges, and the calculated checksum and CRC16 values will be displayed below in the status bar. Press the "OK" button, and you will have completed the creation of a new General Purpose Link Table.

5.2.3.2 Modify General Purpose LINK Table (Mode1, 2) Name

You can follow the procedures described in [Modify ASCII Table Name] in Section 5.1.2, or, during table editing, click on the "Setup" button.
5.2.3.3 Delete General Purpose LINK Table (Mode1, 2)

Follow the procedures described in [Delete ASCII Table] in Section 5.1.3.

5.2.4 ModBus Master Communication Table

5.2.4.1 Create ModBus Master Communication Table

Execute [Project]→[ModBus Master Table]→[Add ModBus Master Table] from the function toolbar; or, click on the icon in the toolbar and select [Add ModBus Master Table] from the dropdown menu; or, in the project window, select [Text Example]→[Table Edit]→[ModBus Master Table] right-click and select [Add ModBus Master Table] as shown below:

As before, in the [Table Edit] window that appears, enter the [Table Name] and whatever other additional items:

Press the “OK” button and the following will appear:
The following procedures are the same as in [Create General CPU LINK Communication Table] in 5.2.1, with features such as “Add”, “Insert”, “Edit”, “Delete”, “Move Up”, “Move Down”, etc. Create three new communication commands, as shown below:

Press the “OK” button, and you will have completed the creation of the new ModBus master table.

5.2.4.2 Modify ModBus Master Communication Table Name

You can follow the procedures described in [Modify ASCII Table Name] of Section 5.1.2, or, during table editing, click the “Setup” button.

5.2.4.3 Delete ModBus Master Communication Table

Follow the same procedures as in [Delete ASCII Table] in Section 5.1.3.
5.3 Servo Parameter Table

5.3.1 Create New Servo Parameter Table

Execute [Project]Æ[Servo Parameter Table]Æ[New Table] from the function toolbar; or, click on the icon in the toolbar and select [New Table] from the dropdown menu; or, in the project window, select [Test Example]Æ[Edit Table]Æ[Servo Parameter Table] right-click on your mouse and select [New Table], as shown below:

As before, enter the [Table Name] items in the [Table Edit] window that appears:

After you press the “OK” button, the following window will appear, enter the appropriate values according to the proper order and item fields:
5.3.2 Modify Servo Parameter Table Name

You can follow the procedures described in [Modify ASCII Table Name] in Section 5.1.2, or, during table editing, you can click the "Setup" button.

5.3.3 Delete New Servo Parameter Table

Follow the procedures described in [Delete ASCII Table] in Section 5.1.3.

5.4 Servo Program Table

5.4.1 Create New Servo Program Table

Execute [Project]→[Servo Program Table]→[New Table] from the function toolbar; or, click on the icon and select [New Table] from the dropdown menu; or, in the project window, select [Test Example]→[Table Edit]→[Servo Program Table] right-click and select [New Table], as shown below:
As before, enter the [Table Name] items in the [Table Edit] window that appears:

Press the "OK" button and the following will appear:

Press the "Add" button, and select the required items and values in the proper order:
The [Operation] field: the “DRV” command is used to operate the motor, while the “ABS” setting uses the absolute coordinates to represent distance of movement, and the “ADR” setting represents the distance of movement in relative coordinates. For example, if the current location was 100mm, and you wish to move to 300mm, then you would want to set the positioning commands to the following:

1. Expressing the movement distance using absolute coordinates:

![Motion Command Item](image)

2. Expressing the movement distance in relative coordinates:

![Motion Command Item](image)

After you press the “OK” button, the following window will appear, and as before, you can select the [Servo Program] that you have already created, and click on the “Insert”, “Edit”, “Delete”, “Move Up”, and “Move Down” functions on the right:
Press the "OK" button, and you have completed the created new Servo command table operation.

### 5.4.2 Modify Servo Program Table Name

Follow the procedures described in [Modify ASCII Table Name] in Section 5.1.2, or, during table editing, click on the "Setup" button.

### 5.4.3 Delete Servo Program Table

Follow the procedures described in [Delete ASCII Table] in Section 5.1.3.

### 5.5 Register Table

#### 5.5.1 Create New Register Table

Execute [Project]→[Register Table]→[Add Register Table] from the function toolbar; or, click on the icon in the toolbar and select [Add Register Table] from the dropdown menu; or, in the project window, select [Text Example]→[Table Edit]→[Register Table] right-click and select [Add Register Table], as shown below:

As before, in the [Table Edit] window that appears, enter the [Table Name] items:
After you press the “OK” button, the following will appear:

![Table Edit window](image)

After you press the “Add” button, the following window will appear:

![Register Table - New Register Table window](image)

After you press the “OK” button, the following window will appear:

Data width: you will have a choice of either a “Word (16-bit)” or “Double Word (32-bit)”. 

![Register Data window](image)

After you press the “OK” button, the following window will appear:
As before, you can also select the [Register Data] that you have already created, and select the “Insert”, “Edit”, “Delete”, “Move Up”, and “Move Down” functions on the right:

![Register Table Interface]

Press the “OK” button, and you have completed the operation for creating a new register table.

### 5.5.2 Modify Register Table Name

Follow the procedures described in [Modify ASCII Table Name] in Section 5.1.2, or, during table editing, click the “Settings” button.

### 5.5.3 Delete Register Table

Follow the procedures described in [Delete ASCII Table] in Section 5.1.3.

### 5.6 Table Configuration

Execute [Project] \(\rightarrow\) [Table Configuration] from the function toolbar; or, click the [Table Configuration] icon from the toolbar, and the following settings window will appear:

![Table Configuration Window]
You can first click on any table name under the [Table List], and then select one of the following buttons on the right-hand side:

1. **[Settings]**: re-set the [Table Name], [Start Address], or descriptions settings for the chosen table.

2. **[Edit]**: re-modify the content and commands in the chosen table.

3. **[Delete]**: deletes the chosen table.

4. **[Update to PLC]**: when there has been an adjustment of settings or modification of contents, you can press this button to update the changes to the Controller.

5. **[Range Check]**: the system will automatically check the table settings, and will list the results under [Message] item, as shown below:

![Table Setup](image)

Therefore, when you are setting and adjusting your tables, you can directly click the “Range Check” button, and you will be able to modify the various tables according to the messages listed under the [Message] item.

### 5.7 Creating and Bringing Up Tables in the Ladder Diagram Using Hotkeys

**Zooming:** rapidly create or bring up tables stored in the Controller with the hotkey “Z”, which can be applied to any function instruction that has table contents, such as communication instruction (FUN151), the high-speed pulse output instruction (FUN140) for NC position control, the parameter setting instruction (FUN141) for NC positioning…etc

**Bring Up Table:**

With the procedures described in Sections 5.1 through 5.6, we can create and modify tables, and we can also obtain information on all tables in a project via the project window, but there is no way of knowing where tables are used in the ladder diagram program, therefore, if a instruction in the ladder diagram program area uses a table output, we could select this function instruction using our mouse, and press the “Z” button, and the settings window for this table will appear, to provide you with a quick and convenient channel for modification and editing.

**Create New Table:**

If, when opening the existing file, you opened the program data in the Controller by executing [File] ➔ [Open] ➔ [Connect to
and choosing not to open the corresponding program, then the project program in the Controller will be brought up and displayed on the screen, and there will be function instruction in the ladder diagram program area, as shown below:

Place the cursor on the above location, and press "Z", then the following confirmation dialog box will appear:

Because Zooming reflects the table content in the Controller program, and not the table content stored in the project in the PC therefore, select “Yes” in this confirmation dialog box, and the following window will appear, and you can create a new Servo command table for the project displayed on the screen:

The frame in the above window is checked and unchecked here, and the created new Servo command table in Section
5.4 cannot select this. Therefore, whenever you enter "motion_0" into the [Table Name] and press the "OK" button, the following confirmation dialog box will appear, confirming whether or not to load the table data from the Controller. It should be noted that only when connected to the Controller can you load data from the Controller.

Press the "OK" button, and the function instruction table selected on the screen will be copied from the table in the project in the Controller and displayed in the project on the screen, and after you have completed the creation process, you will find that a "motion_0" item has been added to the [Servo Program Table] in the [Project Window] in the project on the screen, as shown below:

And now you have completed the procedure for creating a new table in the project displayed on the screen by using the contents of a table stored in a project in the Controller.
Chapter 6 Comments Information

Like other program editors, WinProladder provides a comments feature. Comments can be made for components, networks, or program units. Comments can be hidden or displayed, allowing easy maintenance, and increasing program readability.

### 6.1 Program Unit Comment

When there are many program units, we will need to add comments for the program units, so that future checking and modifications can be performed with more convenience.

**Enter Program Unit Comment:**

Please refer to the procedures described in [Enter Program Unit Comment] in Section 4.3.5.

**Modify Program Unit Comment:**

You can modify comments by using the same method that you used in inputting the original comments, or, you can double-click on the comments display area in the cascaded graphical program area, and you will be able to modify the comments:

![Program Unit Comment](image)

**Delete Program Unit Comment:**

You can take advantage of the program unit description comments modification procedures to clear all descriptive text; or, click on the comments in the ladder diagram program area with your mouse, and press the "Delete" hotkey, which will delete directly.
6.2 Network Comment

In a program unit, there will have many networks of program, and each has its unique function, therefore, if we can annotate each network according to its function, future maintenance of the program can be performed much more conveniently.

6.2.1 Enter Network Comment Mode of Operation

With your mouse, select [Project] → [Comment] → [Network Comment] from the function toolbar, or click the icon in the toolbar; or in the project window, select [Text example] → [Comment] → [Network No.] and double-click, and the [Network Comment] inputting area will appear:

![Network Comment Input Area]

The comments input procedures are as described in [Enter Program Unit Comment] in Section 4.3.5. After you finish inputting:

![Completed Network Comment]

Press the “OK” button, and you will have completed the comments for the solution network:
6.2.2 Choose Single Network Comment Mode of Operation

You can also click the network labeled N000 or its components in the ladder diagram program area, and then right-click and select [Network Comment] from the popup menu that appears, then the input area for [Network Comment] will appear:

![Network Comment Window]

Press the "OK" button, and you will have completed the network comment procedures.

Modifying Network Comment:
Please refer to the procedures described in [Modify Program Unit Comment] in Section 6.1.

Delete Network Comment:
Please refer to the procedures described in [Delete Program Unit Comment] in Section 6.1.

6.3 Element Comment

A program unit is composed of many networks of program, while the networks are composed of various components, therefore, considering the vast number of components in a program unit, there is even greater need to provide comments for the various components.

Enter Element Comment Mode of Operation:
With your mouse, select [Project] → [Comment] → [Element Comment] from the function toolbar, or click on the icon in the toolbar; or in the project window, double-click on [Test example] → [Comment] → [Element Comment] and the [Element Comment] input area will appear:

![Element Comment Window]
Select [All] combined with option [X], and the total amount of used and unused X contact components will be listed in the comments input area, and there will be a check mark beside the used X1 contact reference numbers:

Select [Used] combined with option [X], and then all used X contact components will be listed in the comments input area:

Select [Unused] combined with option [X], and all unused X contact components will be listed in the comments area; select [Export], and the following screen will appear:
Set the export file name; select the items and data ranges that you wish to export, and then press the “OK” button. The exported file will be a text file. You can use this file if you decide to import it one day by selecting the [Import] option, where its settings are the same as the [Export] option. Component comments can be integrated with other software applications via the export and import functions.

The [Refresh] button:
When you open the component comments window, and, at the same time, create a new unused X5 component in the cascaded graphical program area, then the original X5 in the component comments window will be an unused component, but if you press the [Refresh] button, the status of X5 will be changed to a used component.

The [Clear All] button:
It can clear all [Comment] and [Description], as shown below:

After you confirm the clear all operation, all descriptions and comments in the project files will be deleted from the storage.
disk, and if you are connected to the Controller, then the following screen will appear, which represents that the comments and descriptions in the Controller will also be deleted:

![Data Receiving Window]

**The [Clear Unused] button:**

It can clear unused [Comment] and [Description], as shown below:

![Delete Unused Comment]

After you confirm the clear unused operation, unused descriptions and comments in the project files will be deleted from the storage disk, and if you are connected to the Controller, then the following screen will appear, which represents that the comments and descriptions in the Controller will also be deleted:

![Data Receiving Window]

**The [Relocation] button:**

Because component comment and descriptive texts are stored dynamically, therefore the [Relocation] button can re-organize memory allocation and release even more comment space.
The [Set] button:
Set the component comment storage, as shown below:

1. All Store to Ladder(PLC): Store all comments to Controller.
2. All Store to Project: Store all comments to Project
3. Set Range: Is able to set storage range, and then choose to store comments to Controller or Project.

After you confirm the Set operation, all comments will be stored to the choose area, and if you are connected to Controller, then the following screen will display, which represents that the comments in the Controller will also be stored.

Enter Description Mode of Operation:
Double-click on the blank space in the [Comment] area on the right of X0 and enter the comment “Switch”, double-click on the [Description] field and enter “Contact A”:

After you have completed the component comments input, click on the upper right-hand corner and close this window, and you will find that the previously entered comment text has appeared under the X0 component in program unit one,
and that when you place the cursor over X0, a small frame containing the entered descriptive text will appear:

And now you have completed the input of component description comments.

**Modify Element Comment:**

Please refer to the procedures described in [Modify Program Unit Comment] in Section 6.1.

**Delete Element Comment:**

Please refer to the procedures described in [Delete Program Unit Comment] in Section 6.1.

### 6.4 Show Comments

Please refer to the procedures described in [Manipulation of the Comment Display in Ladder Diagram Display Windows] in Section 7.2.
Chapter 7 Manipulating the Display of Ladder Diagram

The most important aspect of this application is that of cascaded program input, therefore, we naturally provide a complete display of information in display windows. The procedure for operation of this display is described in the following.

7.1 Usage of the Windows

We provide multiple window displays for ladder programs, where the user can simultaneously display different segments of the program, and perform convenient operations such as comparing, copying, and editing.

7.1.1 Create Multiple Ladder Diagram Display Windows

A project is divided into the main program area and sub program areas, and they can each create new program pages, as shown in the illustration below. The user can switch between various program areas by clicking the various “Page Label” buttons:
We first place the cursor on the program window “Main_unit1”, then execute [View]→[New Window] from the function toolbar, and the system will open a ladder diagram display 2 window, which includes the program label page for “Main_unit1”, whose content is the same as the content in the “Main_unit1” label page for the original ladder diagram display 1, as shown in the illustration below:

The advantage of this operation is that the ladder programs for "Main_unit1" and "Coin Insertion Count" can be displayed on the screen simultaneously, so that comparisons and copy operations can be performed conveniently between the different sections of the ladder diagram program areas.

7.1.2 The Order of Display for Ladder Diagram Display Windows

Displaying Order for Multiple Ladder Diagram Displays:
Execute [Window]→[Cascade] from the function toolbar:
Displaying Method for Windows that are displayed Side by Side Horizontally:

Execute [Window] → [Tile Horizontal] from the function toolbar:

Simultaneous Display of Multiple Windows Ordered Vertically:

Execute [Window] → [Tile Vertical]:
7.2 Manipulation of the Comments Display in Ladder Diagram Display Windows

The ladder diagram program area provides unit comments, network comments, and component comments. The following describes how to display or hide these comments.

7.2.1 Manipulation of Program Unit Comments Displays

Execute [View]Æ[Program Unit Comment] from the function toolbar. If the option on the left of the text is not checked, then the comments will not be displayed at the top of the ladder diagram program area. After you perform this operation, there will be a check mark in the option on the left of the text:
And this represents that the comments text will be displayed above the cascaded graphical program area:

### 7.2.2 Manipulation of the Network Comments Display

Execute [View] → [Network Comment] from the function toolbar, and a check mark will appear to the left of the text option, which means that the comments text will be displayed above the network of ladder diagram area:

![Network Comment Display](image)

### 7.2.3 Manipulation of Element Comments Displays

Execute [View] → [Element Comment] from the functions toolbar, and a check mark will appear on the left of the options text, and the comments will be displayed below the component in the ladder diagram program area. If you place your cursor on top of the component, a small frame containing the description of the component will appear:

![Element Comment Display](image)
7.3 Manipulation of the Display of Register Data

Execute [View]→[Register Content] from the function toolbar; or press the “F11” hotkey, and the register data will be displayed in the program area:

Before the F11 hotkey has been pressed, the register data is not displayed.
If the [View] → [Element Comment] option had already been selected, then after executing [Register Content], the element comment will be hidden, and the register data will be displayed. If [View] → [Register Content] had originally been selected, then after executing [Element Comment], the register data will disappear, and the component comments will be displayed.

7.4 Direct Display of Specific Program Points

The ladder diagram area is composed of program unit categories, and the various program units are composed of many components, therefore we provide a cascaded method of display in the project window, so that the relative program units, program labels, and steps can all be displayed, allowing the user to be able to quickly display specific program points through the positioning scheme.

7.4.1 Locating Elements through Program Units

In the project window, in the [Main Program Area] and [Sub Program Area] under [Test Examples] → [Ladder Diagram] in the project window, there is a list of the respective program units, as shown in the illustration below:

After the F11 hotkey is pressed, the register content values are displayed.
Double-click on “Main unit1”, and the program for this unit will immediately be displayed, and the cursor will point to the first line in the ladder diagram program area of “Main unit1”.

### 7.4.2 Locating via Program Labels

The various [Label] names are listed under the program units of the [Main Program Area] and [Sub Program Area] under [Test Examples] → [Ladder Diagram] in the project window, as shown below:

Double-click on “TEST”, then the program segment of that particular Label will immediately be displayed, and the cursor will point to that Label.
7.4.3 Locating via Steps

In the [Main Program Area] and [Sub Program Area] under [Test Examples]→[Ladder Diagram] in the project window, there are the respective lists of program units. Double-click on “Main unit1”, and the steps in this program unit will appear, as illustrated in the following illustration:

Double-click on “S0”, and the corresponding step program will be immediately displayed, and the cursor will point to the “S0” step.

7.5 Select Display fonts

Execute [View]→[Font] from the function toolbar, and there will be five options: “Largest”, “Large”, “Medium”, “Small”, and “Smallest”.

7.6 Mnemonic Code Display Control

Place the cursor at the location of the program that you would like to see the mnemonic code for, execute [View]→[Mnemonic] from the function toolbar; or, select the icon from the toolbar, and the mnemonic code window for the solution network at the location of the cursor will be displayed:
Independent mnemonic code windows can at any time display the network mnemonic code programs for the network corresponding to the location of the cursor, and can be used for educational and debugging purposes, where “00000M” represents the place of order in which the instruction is located; “ORG” is a simplified instruction; “M0” is the reference number of the component.

Click the close icon on the upper right corner to close the mnemonic window.

Convert the N0000 network area where the cursor is located to mnemonic code:
Chapter 8 Testing of Application Programs

Prior to the completion of program’s development, the final application program must be downloaded to the Controller and tested. Through the resultant component conduction status, register value display, and status display of status monitoring page, we can judge whether the application program is complete or not.

8.1 On-Line Testing

If you open the file via the off-line method in Section 3.2.1, then execute [PLC] → [On-Line] from the function toolbar; or connect via the “F12” hotkey. After you connect, you can execute [PLC] → [Run PLC] from the function toolbar; or test the program results using the “F9” hotkey. If you open the file on-line via the method described in Section 3.2.2, and you connect successfully, then you can execute [PLC] → [Run PLC] from the function toolbar; or test the program results online by pressing the “F9” hotkey.

8.2 Run Time Status Display

When using on-line Controller testing to test the application program, we can use the bright display of conductive components, register value displays, and component enable/disable displays to check the correctness of the program.

8.2.1 Bright Display of Conductive Components

During on-line testing, conductive components are displayed in bright red color:
8.2.2 Current Register Value Display

When on-line, execute [View] → [Register Content] from the function toolbar; or press the “F11” hotkey, and the result will be:

![Diagram of register value display](image)

8.2.3 Component Enable/Disable Status Display

When on-line, the display of components that are enabled and ON as shown in the illustration below:

![Diagram of component enable/disable](image)

In the function toolbar, [Ladder] → [Control] → [Disable]; or select the X2 component and right-click and select “Disable”, and the following window will be produced:

![Window with component disable option](image)

Then select the “OFF” option and you will see the following illustration:
8.3 Usage of the Status monitoring Page

The status monitoring page can be used to monitor and configure Controller contact statuses and register data. If the monitor point is a contact component, the conduction status and its enable/disable status will also be displayed. You can control the enable/disable status of the contact component and force the contact status to ON or OFF. If the monitor point is a register, then its content value will be displayed and you can modify its value according to your needs. The status monitoring page combined with the ladder diagram program display screen is the best tool and companion for your program testing and debugging needs.

8.3.1 Status Monitoring Page Management

Status monitoring page management operations include creating new status monitoring pages, deleting unneeded status monitoring pages, and renaming status monitoring pages and calling them up. Their operation procedures are described as follows.

8.3.1.1 Creating a New Status Monitoring Page

Execute [Project] → [Status Page] → [New Page] from the function toolbar; or from the project window [Test example] → [Status Page] right-click and select [New Page]; or click the icon in the toolbar and select [New Page] from the dropdown menu and the following window will appear:

After entering the name for the newly created monitoring page, press the “OK” button, and the status monitor table will appear:
8.3.1.2 Deleting Status Monitoring Pages

Execute [Project] → [Status Page] → [Delete Page] from the function toolbar; or in the project window [Test example] → [Status Page] right-click and select [Delete Page]; or click the icon in the toolbar and select [Delete Page] from the dropdown menu and the following window will appear:

Use your cursor to select “StatusPage0”, and it will be deleted.

8.3.1.3 Rename Status Monitoring Pages

Select the status page that you wish to rename from the project window, right-click and select [Rename], and the following will appear:

And you can proceed with the renaming.
8.3.1.4 Call out Specific Status Monitoring Pages

From the function toolbar [Project] → [Status Page] and all status page name will be listed, and then you can simply select the monitoring page that you wish to open; or in the project window, all page name will be listed under [Test example] → [Status Page], and you can double-click on the status page name that you wish to open; or click on the icon in the toolbar, and all status page name will be listed, and you can simply select the monitoring page that you wish to open.

8.3.2 Defining and Deletion of Monitor Points

Defining Monitor Points:
You can enter a reference number for the monitor point, for example R1000, meaning that the monitor point is R1000; or enter a range, for example D0-D4, meaning that the ranges of D0 through D4 are to be monitored.

Deletion of Monitor Points:
Using your cursor, select the reference number of the monitor point that you wish to delete and press the “Delete” button, and only the specific reference number will be deleted. If you wish to delete all of them, you can right-click in the status monitoring page and select [Clear All] from the popup menu.

8.3.3 Monitor Point Status Display Format Control

Right-click in the monitoring page and a popup menu will appear, and shown in the illustration below:
Select “View Element Comment”, then the monitoring page display status will shift into the “Comment” display mode, as shown below:

Select “All Binary” then all [Status] fields in the monitoring page will be displayed binary:
Select “All Hexdecimal”, then all [Status] fields in the monitoring page will be displayed hexadecimal:

Select “All Unsigned Decimal Number Display”, then all [Status] fields in the monitoring page will be changed to unsigned decimal number:

Data Modification:
If you wish to modify the data in reference number R1000, you can double-click on the “1234” data field, and then enter “6789”:

And you will see the data in reference number R1000 has been changed to “6789”: 
Double-click on the status field “Enable” of reference number X0 and you will be able to choose either “Enable” or “Disable”:

Or, right-click to bring up the popup menu shown below, and you will be able to perform the “ON” and “OFF” modification for the X0 status:
8.3.4 Entering the Monitor Point Status

Double-click on the blank space in the [Status Monitoring] window, and the status monitoring input window will appear, and you can input desired monitor reference numbers:

Press the "OK" button:

And you will have completed status monitor point input.
Chapter 9 Operation of the Controller

Our goal is to operate the Controller through the WinProladder programming software; therefore we describe connection to the Controller, disconnection, activation, and stop execution of Controller’s operation procedures in the following.

9.1 On-Line

When connecting to the Controller, the following connection settings will appear:

Including the Advanced, Add, Edit and Delete settings for the Connection Name, and detailed display settings for the connection name. Controller connection can be facilitated through Serial line (RS232/485), Modem, or the Internet, and communications settings files can be established through each of these three connection methods, and then used for subsequent connection operations.

9.1.1 Direct Usage of Existing Connection Settings Files

Select the file that you would like to use for your connection from the [Connection Name] dropdown menu and proceed with the connection operation.

9.1.2 Modify Existing Connection Settings Files

Select the connections settings filename that you would like to modify from the [Connection Name] dropdown menu, and then press the “Edit” button and the following settings window will appear:
9.1.3 Create a New Connection Settings File

In the [Connection] window, press the "Add" button:

Step 1: Enter the desired name "Connection 1" for the connections settings file, and press the "Next" button:

Step 2: Select the hardware to perform the connection through. There are three option types: Serial line (RS232/485), Modem, or the Internet. For [Connection Hardware] settings, please refer to User Manual II – Advanced Applications Chapter 11 [Communication of WSZ-Controller], where WSZ-Controller communications related hardware are described.
in detail.

1. Serial line (RS232/485):
Press the “Next” button, and the communications parameter settings window will appear:

For details on settings editing, refer to User Manual II – Advanced Applications Chapter 11 [Settings for communication parameters].

2. Modem:
Press the “Next” button:
Set the Controller station number and select the modem model, set three dial modes, which are described in the following:

**Using the active dial-up mode:**
Enter “035314991” into the [Phone number] field, and try to connect to the modem of the remote party through the telecommunication system, as shown below:

![Using the active dial-up mode](image1)

**Using the passive listening mode:**
Check the [Using the passive receive mode] option, then the modem will be set to listening mode, and will wait for the remote modem to dial in, as shown below:

![Using the passive listening mode](image2)

**Using the call back mode:**
Check the [Using the call back mode], input the call out telephone number in the [Phone number] field, and enter the call back telephone number in the [Call back number] field. This means that the WinProladder will dial up the telephone number “035314991” first, and then the remote party will call back the telephone number “035457385” if it has successful connection before. The settings is shown as below:

![Using the call back mode](image3)
For a further description of the above three MODEM dialing modes, please refer to User Manual II - Advanced Applications Chapter 11.

3. Internet:

For [Protocol], select UDP or TCP, set the [Station Number], [IP] and [Port Number].
Step 3: Press the “Finish” button, and you will have completed the procedure for creating a new connection settings file. Select a connection name and press “Delete”, and you can delete the selected connection settings file.

![Image](image1.jpg)

9.2 Off-Line

When connected to the Controller, simply execute [PLC] → [Off-Line] from the function toolbar.

9.3 Run Controller

When connected to the Controller, simply execute [PLC] → [Run PLC] from the function toolbar; or press the “F9” hotkey.

9.4 Stop Controller

When the Controller is in operation, you can execute [PLC] → [Stop PLC] from the function toolbar; or press the “Ctrl” + “F9” hotkey to stop Controller operation.

9.5 Clear Controller

When connected, execute [PLC] → [Clear PLC] from the function toolbar, and the following data clearing options will appear:

![Image](image2.jpg)

Select one of the four options- Clear all (Initialization), Only Ladder Program, Only Register and Only Coil according
9.6 Controller Setting

When connected with the Controller, you can set the PLC ID, station number, communications parameters, and communications protocol settings for the Controller. The procedures are described as follows:

9.6.1 Setting-PLC ID

Execute [PLC] → [Setting] → [PLC ID] from the functions toolbar, and the following illustration will appear, enter the PLC ID which is identical to the program ID:

![Change PLC ID window](image)

9.6.2 Setting-Station Number

When connected, execute [PLC] → [Setting] → [Station Number] from the function toolbar and the following settings window will appear:

![Station Number window](image)

9.6.3 Setting-Port Parameters

When connected, execute [PLC] → [Setting] → [Port0 Parameter] from the function toolbar and the following [Comm. Parameters Setting - Port0] settings window will appear:

![Comm. Parameters Setting - Port0 window](image)
It can set the communication parameters for needs: Port0 ~ Port4, Port3 and Port4 are unused.

### 9.6.4 Setting-Protocol

When on-line, execute [PLC] → [Setting] → [Protocol] from the function toolbar and the following settings window will appear:

![Setting-Protocol Window]

### 9.6.5 Setting-Calendar

When the Controller is in [On-Line] status and is in [Run PLC], execute [PLC] → [Setting] → [Calendar], and the following window will appear, and you can set the time for the Controller’s built-in calendar:

![Setting-Calendar Window]
"PLC current time" is the current time taken from the Controller under connected conditions, in the [Setup] field, check "Apply PC time", then the PC time will be displayed in the next field, then click the "Update PLC time" button, and the [PLC current time] will be changed to the current time in the PC; if the "Apply PC time" is unchecked, then the [Date] and [Time] settings in the next fields can be modified, then press the "Update PLC time" button, and the [PLC current time] will be changed to the currently set time.

9.6.6 Setting-Phone Number

When connected, execute [PLC] → [Setting] → [Phone Number] from the function toolbar and the following settings window will appear:
9.7 Quick Control

WinProladder versions 2.0 and earlier had to wait long periods of time (in large programs) before being able to obtain any
information from the Controller. This became a large and unnecessary overhead if all you wanted to do was obtain the
status of the Controller or initialize the Controller. Therefore, in versions 2.0 and later, we added “Quick Control” feature,
allowing users to quickly read the status of the Controller and initialize the Controller without having to connect to the
Controller:

9.7.1 Get System Status of Controller

When off-line, select [PLC] → [Quick Control] → [Get System Status of PLC] from the function toolbar and you will be able
to read Controller information.

And Press “OK” button.
9.7.2 Initialize Controller

When off-line, select [PLC] → [Quick Control] → [Initialize PLC] from the function toolbar, and you will be able to initialize the Controller if successful connection:

And Press “OK” button.

Then Press “YES” button.
Chapter 10 Ladder Program Simulation

10.1 Features

- Can simulate the WSZ-Controller ladder program execution without Controller connection.
- With providing single/multiple/continuous scan mode, the execution result at each scan end can be easily checked.
- With providing program address breakpoint and data breakpoint, it is convenient to check any intermediate execution result and to identify any data changed.
- Provides communication interface allows external program or device (For example, graphic panel or HMI) to modify or monitor the variable value during the simulation.
- With run time editing feature, during the simulation process the program can be modified without stop the execution.

10.2 Limitation of Program Simulation

Besides the I/O operation, most of the instructions can be simulated. When the ladder program contains the unsupported instruction, the operation of unsupported instruction will be ignored and will be shown with yellow background color as following.

10.3 Operation of Program Simulation

The following is an example of "ssi.pdy" project, with this project to explain the related operations for program simulation.

10.3.1 Open Ladder Program

Follow the following function toolbar operation to open the "ssi.pdy" project file.

[File] → [Open] → [Open] → select ssi.pdy. After select the project, the screen will display as below:
10.3.2 Enter Simulation Mode

Function toolbar: [PLC] → [Simulation]
It will enter into the simulation mode after execution.

10.3.3 Start Execution of Program Simulation

Function toolbar: [PLC] → [Run]
After execution, the color of power line of ladder program will become to red color as the screen shown as below:

During the execution, there is a blinking red dot at the left side of status bar. On the right of the red dot has SC: xxxx, xxxx means the number of time has been scanned. During simulation, can use the status monitoring page to monitor or modify the value of register or discrete point.

10.3.4 Pause of Program Simulation

Function toolbar: [PLC] → [Pause Simulation] or the easiest way is to press "Alt+space" key
At this point, the blinking red dot stop blinking and it will become pink color.
10.3.5 Proceed to Program Simulation

Function toolbar: [PLC] → [Resume Simulation] or the easiest way is to press "Alt+space" key
At this point, the dot becomes blinking again and the program continues the operation.

10.3.6 Control Scanning

The above pause/Resume program simulation is operated by manual way of controlling the program execution, which will pause the program execution at the next scan end point right after you issue the command. But if you would like to control the exact times of scan execution after pause, you can use set scan mode to control.

10.3.6.1 Single Scan

Function toolbar: [PLC] → [Setup Simulation] choose "single scan"

After set this mode, you can use "Alt+space" key or
Function toolbar: [PLC] → [Resume Simulation] to start a new scanning work.

10.3.6.2 Multiple Scan

Function toolbar: [PLC] → [Setup Simulation] choose "multiple scan"
After selecting the mode, you can set number of scans to be performed in [Scan Times] field.

After that, press "Alt+space" key or Function toolbar: [PLC] → [Resume Simulation] to start up next scanning work. When the scan has reached the set number, it will pause the scanning.
10.3.6.3 Continuous Scan

Function toolbar: [PLC] → [Setup Simulation] choose “continuous scan”
This is the default scan mode after entering the simulation.

10.3.7 Set Address Breakpoint of Program Execution

In addition to the above methods to make the program paused at the scan end point, can also use the following method to pause the program at a specific network number.
Please first select the network to be set break point and then execute the
Function toolbar: [PLC] → [Add/Remove Address Breakpoint]
Or in the ladder diagram window, on the “Network Display” region click the right button of the mouse and popup the menu.
Popup Menu: Add/Remove Address Breakpoint
The network with breakpoint set will display a red dot, which is as shown in the picture below:

![Network Breakpoint Example]

The above picture indicates N001 has been set to an address breakpoint. When every time right before execution of this network, it will pause the program execution. The user can press “Alt+space” key for continuing the program execution.
The address breakpoint can be set up to 16 points at same time.

10.3.8 View Address Breakpoint List

When there are many address breakpoints have been set, can use this feature to quickly remove, pause or enable the setting of address breakpoints.
Function toolbar: [PLC] → [View Address Breakpoints]
After execution, it will display the following window:
This window will show all the existed address breakpoints. The checked mark in [Enabled] field means corresponding address breakpoints are in effective. You may use right click to call the pop-up menu shown in below:

- Enabled: Activate the breakpoint.
- Disabled: Inactivate the breakpoint. When disabled, the red dot of the corresponding network will become a gray dot.
- Erase: clear the breakpoint.
- Erase All: remove all breakpoints.

If you double click the breakpoint in the list, it will display the corresponding breakpoint in the ladder diagram window.

**10.3.9 Setup Data Breakpoint**

Use this feature will make the program pause when the value of a specific contact or register changed or change into a certain values.

Function toolbar: [PLC] → [Setup Data Breakpoint]

After operation, it will display the window as shown in below

The left screen will be shown when the “Enable” field is not checked while the right screen is checked.

When check the “Enabled” checkbox, the setup fields will appear. Description is as follows:

- Ref. No.: Register (Word or Double word) or contact reference number.
- Data: Conditions of match value
- Condition: three options
  - Change to – When value of Ref. No. (Monitoring variable) is changed to the “Data” value, the execution will be paused.
  - Change not to –When value of Ref. No. (Monitoring variable) is changed to a value not equal to “Data” value, the execution will be paused.
- Changed –Whenever the value of Ref. No. (Monitoring variable) is changed, the execution will be paused.

This feature can easily be used to identify the source of any changes of monitored variables.

**10.3.10 Stop Simulation**

Simulate the Controller “stop” operation, when next time execution (RUN), it will simulate the initial operation.
Function toolbar: [PLC] → [Stop PLC]

**10.3.11 End Simulation**

Exit the simulation mode.
Function toolbar: [PLC] → [End Simulation]

**10.4 Communicate with Simulation Program**

When perform the simulation, besides “WinProladder” software, other devices or software can also monitor or modify the status of variables, though serial port or TCP/IP network interface by using the Original communication protocol. The most common practice is to combine the HMI and ladder simulation to perform the integrated test.

There should be noted that, this feature only provides WSZ-Controller slave communication capability. The function block FUN 150, 151 and real I/O related functions are not supported in simulation.

**10.4.1 Communication Function Setup**

You may choose serial ports or TCP network. The setup method is as follow:
Function toolbar: [PLC] → [Setup Simulation] and then please select “Communication” tab.
In this page, please check “Enabled” checkbox and then it will display the following window.

![Simulation Setup Window](image)

**10.4.1.1 Serial Port Communication Setup**

After select “Serial”, press “Edit”. Fill in the simulated communication parameters.
In addition, the “Port No.” means the port number on PC.
10.4.1.2 Internet Communication Setup

TCP network is not supported in the WSZ series.
Chapter 11 Constructing Projects

When constructing a project, to ensure that the project has been well designed with intellectual protection and for long term maintenance and easy modification, it needs to provide detailed information regarding project information, program security settings, and system configurations. The following is a description of the settings related to construct a project.

11.1 Modifying Project Information

Execute [Project] → [Project Information] from the function toolbar, and the project information window will appear, and you can proceed with the modifications:

Please refer to [Establish New Project] in Section 3.1 for a description of how to conduct the settings process.

11.2 Program Security Settings

Most systems adopt a password approach for intellectual property protection. With WSZ-Controller, in addition to passwords, we also provide security measures such as program ID and PLC ID, providing an additional layer of security to help protect the results produced through the user’s painstaking research and development.

11.2.1 Set the Program Password

Execute [Project] → [Project Setup] → [Password] from the function toolbar and the following window will appear:
After you have entered the password, all subsequent access to the project will require inputting this password to protect the program. When the program designer only wishes to open the main program area for public access, and does not wish to allow public access to the sub program area, then the "Protect Sub-Program Only" option can be selected, and the sub program area will be protected.

### 11.2.2 Set the Program ID

The program password can prevent illegal copying of the program, which can provide a certain degree of protection, but it cannot help against preventing program hardcopies (If MEMORY Pack being used, it is easy to take out and install on some other Controller main unit for working), in these circumstances, the password will not be able to protect the program. In this situation, setting a program ID that must be identical to the PLC ID can prevent hardcopies, thereby providing a further degree of security.

Execute [Project] → [Project Setup] → [Program ID] from the function toolbar, and the following window will appear:

Now you can set the program ID; if a program has the program ID setting, then the Controller that wishes to execute this program must have a PLC ID set to be same with program ID, otherwise the Controller will not be able to operate.

### 11.3 Program Conversion

We cannot use this function.
11.4 Set System Configurations

System configurations include I/O settings, memory allocation, and read-only register settings.

11.4.1 Set I/O Configuration

Execute [Project] → [I/O Configuration] from the function toolbar; or click the icon in the toolbar; or in the project window, click [Test example] → [System Configuration] → [I/O Configuration] twice, and the I/O configuration window will appear:

![I/O Configuration Window](image)

11.4.1.1 Configure the Counter/Timer Settings

As shown in the illustration below, configure the [Counter] page, the WSZ-Controller has 4 HHSC (Hardware High-Speed Counter), and 4 SHSC (Software High-Speed Counter) in which the 4 HHSC (HSC0~HSC3) have 8 counting modes, which can be selected in the [Counting Mode] dropdown menu in the illustration below; and the 4 SHSC (HSC4~HSC7) have 3 counting modes, which can be selected in the [Counting Mode] dropdown menu shown in the illustration below.
For the HHSC, because A/B inputs must be used in pairs, if you select the “A/B” [Counting Mode], and select “X0” for the [A-Phase] field, then “X1” will automatically be chosen for the [B-Phase] field, and you will not be allowed to modify this. As shown below:

If “K/R” or “U/D” is chosen for the [Counting Mode], then the inputs can be entered separately. To achieve optimal results, the input point distribution is as follows:

<table>
<thead>
<tr>
<th>HHSC0</th>
<th>HHSC1</th>
<th>HHSC2</th>
<th>HHSC3</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pulse</td>
<td>Dir</td>
<td>Pulse</td>
<td>Dir</td>
</tr>
<tr>
<td>Up</td>
<td>Down</td>
<td>Up</td>
<td>Down</td>
</tr>
<tr>
<td>X0</td>
<td>X1</td>
<td>X1</td>
<td>X5</td>
</tr>
<tr>
<td>X4</td>
<td></td>
<td></td>
<td>X5</td>
</tr>
</tbody>
</table>

The meaning of the points that appear repeatedly is, for example, you can just set one point for HHSC0, and save X1 for HHSC1 to use, and if you use the distribution method described below, a main unit will be able to complete 4 sets of hardware high-speed counters (without considering the directions):

The 3 counter modes for the SHSC are: U/D, P/R, A/B.

(For descriptions of the above counter modes, please refer to User Manual II – Advanced Applications Chapter 10.)

<table>
<thead>
<tr>
<th>HHSC0</th>
<th>HHSC1</th>
<th>HHSC2</th>
<th>HHSC3</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pulse Up</td>
<td>Dir Down</td>
<td>Pulse Up</td>
<td>Dir Down</td>
</tr>
<tr>
<td>X0</td>
<td>X1</td>
<td>X4</td>
<td>X5</td>
</tr>
</tbody>
</table>

Select the [HSC0] counter setting, choose “Hardware Counter” for [Counter Type], select “U/D” for [Counting Mode], representing that single-phase independent upward/downward high-speed counters have two independent upward (U) and downward (D) pulse inputs, and these two are independent and unrelated. Therefore, the following will appear after you have chosen “U/D”:

[Up (UP)]:
if “X0” is chosen for this field, then the current counting value will increment by 1 at the rising-edge of the X0 pulse input.

[Down (DN)]:
if “X1” is chosen for this field, then the current counting value will decrease by 1 at the rising-edge of the X1 pulse input.

[Mask (MSK)]:
if “X2” is chosen for this field, then when the X2 signal is a 1, the HSC counter pulse will be masked and will not count, while the internal states of the HSC will be fully preserved. When X2 goes back to 0, HSC will go back to normal operation.

[Clear (CLR)]:
if “X3” is chosen for this field, then when the X3 signal is a 1, the internal CV register of the HSC will be cleared to a 0, and cannot count, and only when X3 goes back to 0, will HSC begin counting from 0. After completing the settings, the “Undefined” content of the X0~X3 status in the [Utilization] window on the left will be changed to the settings contents.

[Mask signal] field:
can choose to reverse or non-reverse the Mask input signal.

[Clear signal] field:
can choose to reverse or non-reverse the Clear input signal.
[Counter signal] field: can choose to reverse or non-reverse the Count input signal.

[HSC’s Data Length] field: you can select “32-Bit Hardware Counter” settings or “16-Bit Timer + 16-Bit Counter” mode.

11.4.1.2 Configure the Interrupt Signal Settings

Select the [Interrupt Setup] page:

Interrupt refers to a signal sent to the CPU requesting immediate service, during the routine sequential execution of cycles and scanning; when the CPU receives an interrupt request, it immediately discontinues the scanning operation that it is executing, and proceeds with the “Service Requested by Interrupt” first; and the CPU will return to the interrupted scanning operation after the service is complete.

The service specified by the interrupt request, i.e. the “Interrupt Service Program”, must have a one and only “Interrupt Label Name”. For the interrupt label names and interrupt priorities of the 49 WSZ-Controller interrupts, please refer to Section 9.3 [Interrupt Source, Label and Priority for WSZ-Controller] in User Manual II - Advanced Applications Chapter9. The rising and falling edge settings for X0~X15 in [Interrupt Setup] represent the interrupt occurrence conditions for the interrupt priority 18 ~ 49 “Interrupt label names”.

![Interrupt Setup Page](image.png)
11.4.1.3 Configure the Output Settings

Select the [Output Setup] page:

[Retentive Output Coil]: when Yn is selected, the Yn output will be preserved in the case of a power-off.

[HSPSO]: WSZ-Controller can provide 20KHz~200KHz high-speed pulse output. WSZ-xxMCT2-AC can provide 20KHz~/200KHz (single-end) output.

High-speed pulse output circuits share the WSZ-Controller external output points Y0~Y7. When the HSPSO function is not utilized (the PSO function has not been configured), the Y0~Y7 external output points of the WSZ-Controller are mapped to the internal statuses Y0~Y7 of the Controller. But when the HSPSO has been configured, then the external output points Y0~Y7 will directly switch to the HSPSO output circuits internal to the ASIC, and will have nothing to do with the Y0~Y7 status in the Controller.

The following is a table showing the signal descriptions of the output points of the various axles of the main unit and the selectable output modes; the [High-Speed Pulse Output] settings can be set according to the following table:

<table>
<thead>
<tr>
<th>Axle number</th>
<th>External output point</th>
<th>U/D output</th>
<th>PLS/DIR output</th>
<th>A/B output</th>
<th>Single-point PLS output</th>
</tr>
</thead>
<tbody>
<tr>
<td>PSO0</td>
<td>Y0</td>
<td>Y0=U</td>
<td>Y0=PLS</td>
<td>Y0=A</td>
<td>Y0=PLS</td>
</tr>
<tr>
<td></td>
<td>Y1</td>
<td>Y1=D</td>
<td>Y1=DIR</td>
<td>Y1=B</td>
<td></td>
</tr>
<tr>
<td>PSO1</td>
<td>Y2</td>
<td>Y2=U</td>
<td>Y2=PLS</td>
<td>Y2=A</td>
<td>Y2=PLS</td>
</tr>
<tr>
<td></td>
<td>Y3</td>
<td>Y3=D</td>
<td>Y3=DIR</td>
<td>Y3=B</td>
<td></td>
</tr>
<tr>
<td>PSO2</td>
<td>Y4</td>
<td>Y4=U</td>
<td>Y4=PLS</td>
<td>Y4=A</td>
<td>Y4=PLS</td>
</tr>
<tr>
<td></td>
<td>Y5</td>
<td>Y5=D</td>
<td>Y5=DIR</td>
<td>Y5=B</td>
<td></td>
</tr>
<tr>
<td>PSO3</td>
<td>Y6</td>
<td>Y6=U</td>
<td>Y6=PLS</td>
<td>Y6=A</td>
<td>Y6=PLS</td>
</tr>
<tr>
<td></td>
<td>Y7</td>
<td>Y7=D</td>
<td>Y7=DIR</td>
<td>Y7=B</td>
<td></td>
</tr>
</tbody>
</table>

In the table, the “Single-Point PLS output” mode provides users with a mono-direction high-speed pulse output, and can therefore save output points for designers that only need one high-speed output point, which can be very useful.

[Output Polarity] field: select inverted or non-inverted for pulse output.
11.4.1.4 Configure the Input Settings

Select the [Input Setup] page:

**Captured Input Configuration:**

- **[Set All]:** set all X0~X35 inputs to captured Input.
- **[Reset All]:** cancel all X0~X35 captured Inputs.

**[Digital Filter Configuration]:** divide X0~X35 into 6 groups.

<table>
<thead>
<tr>
<th>Group</th>
<th>Inputs</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>X0~X3</td>
</tr>
<tr>
<td>2</td>
<td>X4~X7</td>
</tr>
<tr>
<td>3</td>
<td>X8~X11</td>
</tr>
<tr>
<td>4</td>
<td>X12~X15</td>
</tr>
<tr>
<td>5</td>
<td>X16~X23</td>
</tr>
<tr>
<td>6</td>
<td>X24~X35</td>
</tr>
</tbody>
</table>

※ For descriptions of captured Inputs and digital filtering, please refer to Section 9.7 of User Manual II - Advanced Applications

11.4.1.5 Configure Temperature Module Settings

If the Controller system exist the temperature expansion module, it will automatically detect and distribute the I/O reference address to it. For details, please refer to Section 13.6 [I/O Reference Number Allocation statuses].
The example in the above illustration shows the WSZ-24MCT2-AC main unit has two expanded temperature modules WSZ-16TC. To configure the expansion modules, click [Temp. Configuration] and shown as below:

[Starting Address of Configuration Table]: the registers of table store configuration information regarding the temperature modules. For detailed descriptions, please refer to User Manual II - Advanced Applications Chapter 20 [Temperature Measurement of WSZ-Controller and Temperature PID Control].

[Starting Address of Temperature Register]: sets the beginning register address for the current reading values of temperature measurement; each channel is mapped to a register. In the example, one WSZ-16TC module and one WSZ-16TC module, adds up to a total of 32 channels, and therefore needs 32 registers.

[Starting Address of Working Register]: these registers are needed for the internal operation of the Controller system for temperature module’s working. For detailed descriptions, please refer to User Manual II - Advanced Applications Chapter 20 [Temperature Measurement of WSZ-Controller and Temperature PID Control].

[Sensor Type]: the types and ranges of selectable temperature sensors are listed in the following table:

<table>
<thead>
<tr>
<th>Sensor Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>J (-200 ~ 1200°C)</td>
</tr>
<tr>
<td>K (-190 ~ 1300°C)</td>
</tr>
<tr>
<td>R (0 ~ 1800°C)</td>
</tr>
<tr>
<td>S (0 ~ 1700°C)</td>
</tr>
<tr>
<td>E (-190 ~ 1000°C)</td>
</tr>
<tr>
<td>T (-190 ~ 380°C)</td>
</tr>
<tr>
<td>B (350 ~ 1800°C)</td>
</tr>
<tr>
<td>N (-200 ~ 1000°C)</td>
</tr>
</tbody>
</table>

[Unit of Temp.]: the user can select either Celsius or Fahrenheit temperature representations.

[Times of Average]: you can calculate the averaged value of the measured temperatures. The selectable options are: “No”, “2”, “4”, and “8”.

[Scan Rate]: select the “Normal” (With 0.1° resolution) or the “Fast” (With 1° resolution) refresh rate for temperature measurement.
11.4.1.6 Configure the AI Module Settings

If there are analog input expansion modules in the Controller system, it will detect and distribute the I/O reference address for access. For detailed descriptions, please refer to Section 13.6 (I/O Reference Number Allocation Statuses).

The above illustrated example shows a WSZ-24MCT2-AC main unit has a WSZ-6AD expansion module, and this module occupies six analog input registers R3840~R3845 as the reference address for access. To configure this module, click [AI Configuration], it will show the screen:

[AI Data Format]: It can be 12-bit or 14-bit format for representation
[Valid Bits]: if the analog input format is set to 12-bit, then the effective number of bits will be set at 12 and cannot be changed. If the analog input format is set at 14-bit, then the effective bits setting can be set to either 12-bit or 14-bit, and the AI reading values are all in 14-bit representation.

[Times of Average]: it can give the number of average for reading value calculation, which can be at least 1 time (No average), and at most 16 times. But it should note that the higher the average value, the more times it will take to refresh the reading value.
11.4.2 Configure the Memory Allocation Settings

Execute [Project] → [Memory Allocation] from the function toolbar; or click on the icon in the toolbar; or in the project window, select [Test example] → [System Configuration] → [Memory Allocation] and double-click, and the memory allocation settings window will appear:

When the Controller main units are manufactured (They are set to factory defaults), the system construction settings, such as for (Retentive) and (Non Retentive) coils, or for the specified allocation of registers, read-only register ranges, have all been planned and set to appropriate values. We refer to this configuration as the Default Configuration. Under most circumstances, the user does not need to change the default configurations. Only in various more complex or specialized applications, does the user need to modify the default configurations, and this feature is meant to provide a means to do so with the WSZ-Controller. By pressing the “Reset to Default” button, you can set the system settings back to the initial default settings. After pressing the “OK” button, you will have completed the memory allocations setting procedure:
The value of non-retentive type relays and registers will be cleared to 0 after a power-up or a Controller STOP → RUN operation, while the retentive types will still be set to the value prior to the power-down or STOP. The following is a description of their various characteristics.

### 11.4.2.1 Set the Number of Internal Coils in the Retentive-Type

The settable range for the internal coil quantity of retentive-types is 0~1400. If you enter "600", you will distribute a quantity of 600 to the internal coil of retentive-types, and therefore you will first allocate range M0~M799 (a total of 800 in quantity) to non-retentive type internal coils, thereby setting the range for retentive-type internal coils to M800~M1399 (a total of 600 in quantity). Internal coils can be modified, please refer to the description in Section 2.2 of User Manual I – Hardware & Instruction.

### 11.4.2.2 Set Retentive-Type Step Coil Quantities

The settings range for retentive-type step coil quantities is 0~980. If you enter “500”, you will allocate 500 in quantity to retentive-type step coils, while steps S0~S19 will always be non-retentive and cannot be changed, therefore the step coil range is 0~999, therefore the system will first allocate the range S0~S499 (a total of 500 in quantity) to the non-retentive type step coils, and therefore the step coil allocation range for retentive-type will be S500~S999 (a total of 500 in quantity). The step coils can be modified, please refer to the description in Section 2.2 of User Manual I – Hardware & Instruction.

### 11.4.2.3 Set Timer Time Base Amount Allocation

The settings range for timer quantities is 0~256, and timer timing bases are divided into 0.01 second, 0.1 second, and 1 second timing methods. Therefore, if you enter “50” in the 0.01 second field, you will allocate 50 quantities to the 0.01 second timer, and therefore the T0~T49 (a total of 50 quantities) range will first be allocated to the 0.01 second timer; and then enter “150” in the 0.1 second field, which represents that 150 quantities will be allocated to the 0.1 second timer. Therefore range T50~T199 (a total of 150 quantities) will be allocated to the 0.1 second timer; and therefore the remaining 56 quantities will be allocated to the 1 second timer, and the range of allocation will be T200~T255 (a total of 56 quantities). Timers can be modified, please refer to the description in Section 2.2 of User Manual I – Hardware & Instruction.

### 11.4.2.4 Set the Quantity of Retentive-Type 16-bit Counters

Retentive 16-bit counter quantities have range settings of 0~200. If you enter “140”, you will have set the quantity of retentive 16-bit counters to 140, therefore retentive 16-bit counters have allocation ranges of C0~C139 (a total of 140). Retentive-type 16-bit counters can be modified, please refer to the description in Section 2.2 of User Manual I – Hardware & Instruction.
11.4.2.5 Set the Quantity of Retentive-Type 32-bit Counters

Retentive 32-bit counter quantities have range settings of 0~56. If you enter "40", you will have set the quantity of retentive 32-bit counters to 40, therefore retentive 32-bit counters will have allocation ranges of C200~C239 (a total of 40). Retentive-type 32-bit counters can be modified, please refer to the description in Section 2.2 of User Manual I – Hardware & Instruction.

11.4.2.6 Set the Quantity of Retentive-Type Data Registers

The quantity settings range for retentive-type data registers is 0~3840. If you enter "3000", you will have allocated 3000 retentive-type data registers, and therefore the allocation range of retentive-type data registers will be R0~R2999 (for a total of 3000). Retentive-type data registers can be modified, please refer to the description in Section 2.2 of User Manual I – Hardware & Instruction.

11.4.2.7 Set the Amount of Read-Only Registers

The settings range for read-only registers is 0~3072. If you enter "0", you will have allocated 0 to read-only registers, and therefore read-only registers will not have an allocation range. Read-only registers can be modified, for a description of settings ranges, please refer to User Manual I – Hardware & Instruction page 2-2.

11.4.3 Configure Read-Only Register Content

Execute [Project] → [ROR Register] from the function toolbar; or click the icon from the toolbar; or in the project window, select [Test example] → [System Configuration] → [ROR Register] and double-click. Continuing with the un-configured read-only register range in Section 11.4.2, the following window will first appear:

The allocable range for read-only registers is R5000~R8071 (a total of 3072 quantities), and if no range is allocated to read-only registers, then R5000~R8071 can be used as general registers of the retentive type. Press the "Yes" button, and re-set the quantity of read-only registers, enter "200", and the allocation range for read-only registers will be R5000~R5199 (for a total of 200):
Press the "OK" button and the read-only memory data, comments, and description input areas for R5000~R5199 will be listed:

The advantage of setting read-only registers is that the content of the registers will be saved along with the project files, therefore, when you save the project to the Controller, if you have specified read-only registers in the project, then these read-only registers will carry the values that you specified even at the very beginning of system initialization.
Chapter 12 Tabular Outputs

After the program is completed, naturally you would want to print some relative descriptions of the program or comments, but before you do, you will need to configure the printer, or select the settings for the items to be printed. The operation procedures are described in the following:

12.1 Printer Settings

Execute [File] → [Printer Setup] from the function toolbar, and perform the printer configuration:

12.2 Printing Settings

Execute [File] → [Print Content Setup] from the function toolbar; or use the hotkey “Ctrl” + “P”. Perform the print settings for the program content, as described below:

12.2.1 Select the Ladder Program that you would like to Print

In the [Print] window, select the [Edit Network] page:

For the [Program Unit] field, select the first program unit item “Main_unit1”, and then press the “Append” button, then the program unit “Main_unit1” will be listed under [Print Items] to the left; the “Select All” button can be used to select all of the program units listed under [Program Unit], press the “Append” button again, and all the program units will be listed under
[Print Items] on the left to be prepared for printing. If you check “Network Comment” for [Print Items], then the network comments for the program unit will be printed:

If you press the “Print Setup” button, you will go to the [Printer Settings] screen in Section 12.1, and will be able to re-configure the printer; if you press the “Preview” button, you will be able to preview the screen that you wish to print:

Press the “Print Setup” button and you will go to the [Printer Settings] screen in Section 12.1, and you will be able to re-configure your printer; press the “Print” button and printing will begin; if there is more than one page, you can press the up and down buttons; press the “Zoom” and “Reduce” buttons to adjust the preview image; use the “Close” button to go back to the print window.
12.2.2 Select the Descriptions and Comments that you wish to Print

In the [Print] window, select the [Comment / Description] page:

[Data Range] will list the following three categories: program unit comments, network comments, and component comments. For example, if you select the comments for the first program unit, and press the “Append” button, then you will also list this item under [Print Items] on the left:

Press the [Preview] button and the entire program unit comments will be printed on the first page in the preview screen, as illustrated below:

If you select the “Coin Insertion Count” item under [Data Range], then the Network Comment for the “Coin Insertion Count” program unit will be printed; if you press the “Append” button, and add the [Print Items] listed on the left, then the network comments in “coin insertion count” program unit will be printed.
If you select the "Input Contact" item in [Data Range], and check the "Element Comment" option in the [Print Items] on the right, then the text of the [Comment / Description] will be printed; if you check the "Register Data" option in [Print Items] then the data or values in the registers of the component will be printed; press the "Append" button, and add the [Print Items] listed on the left, and the following will be printed: the component comment of the input connection point, descriptions, and register data and values. The following is the preview screen for an "Input Contact" item:
12.2.3 Select the Table that you wish to Print

In the [Print] window, select the [Table] page:

All of the tables you created will be listed under [Tables List]. For example, if you select "General CPU LINK Communication Table", and press "Preview", the settings content for the table will be printed. There are three data items in the following table:

If you check the "Data or Value" option in [Print Items], then the data and values for R6000~R6021 will be printed during print preview.

12.2.4 Select the Status Monitoring Page that you wish to Print

In the [Print] window, select the [Status Page] page:

Under the [Status Page List] category, you will find a list of all the monitoring pages that you created, choose the first item "Status Page 0", and add it to [print item] on the left; check the "Printing Reference number" option under [Print Items], then the print preview screen will be as follows, displayed according to “No.”:
Check “Print Comment” in [Print Items], and the preview screen will be as follows, displayed according to “Comment”:

12.2.5 Select the Project Information or Configuration that you wish to Print

In the [Print] window, select the [System / Other] page:

The following three system configurations of project will be listed under [Other Item]:

1. **[I/O Configuration]**: will be printed according to the [Set I/O Configuration] settings made in Section 11.4.1.
2. **[Memory Allocation]**: will be printed according to the [Set Memory Allocation] settings made in Section 11.4.2.
3. **[ROR Registers]**: will be printed according to the [Set Read-Only Register Content] settings made in Section 11.4.3.
12.2.6 Set Print Format

In the [Print] window, select the [Format Setup] page:

[Printing margin Setup]: set the upper, lower, left, and right margins in units of mm. The status and changes in the margin settings will immediately be shown in [Format Preview].

[Paper Size]: the width and height of the paper will be displayed according to the paper size settings specified in the printing settings.

[Page Heading / Page Tail Setup]: press this button and the following settings page for the title at the top of the page and the page number at the end of the page will appear, as shown below:

Page Heading

[Print Header]: enter the “Print Test” title into the text area, you can also make changes to the font type using the “Font” button, and then check “Print Header”, and then this title will be printed.

[Print File Name]: if selected, the project file path will be printed.

[Date of Print]: if selected, the print date will be printed.

Page Tail

[Print Page Num]: if selected, page numbers will be printed. The following settings will only have meaning when this setting is selected.
[Alignment]: you can choose to position the page number by aligning to the left, aligning to the right, or placing in the center.

[Page Number Format]: page number format settings, # represent the current page number, $ represents the total number of pages.

12.3 Print Preview

You can preview the result of all of your settings in the printing settings window via the “Preview” button. Only when you are satisfied with the settings should you “Print”. We have already shown the [Preview] screens for the settings in Sections 12.2.1 through 12.2.5, the following is the [Preview] screen for the settings described in Section 12.2.6:

12.4 Printing

After you have completed the settings in the [Print] window, you can press the “Print” button to print; or in the print preview screen, you can execute [File] → [Print] from the function toolbar, or click the “Print” button in the toolbar to print.
Chapter 13 Auxiliary Functions

The WinProladder software also provides auxiliary functions, like the CRC16/Checksum calculator which allows the user to enter data for calculation and produce values for checking; the contact and register usage information features provide overall usage tables for the various contact components and registers; also provided are register content backup, register content backup recovery, and four different MEMORY Pack operation modes, which are described in detail below.

13.1 CRC16/Checksum Calculator

Execute [Tool] → [CRC16 Generator] from the function toolbar and the following window will appear:

Enter the code that you wish to check; this function will display the number of bytes (Len) currently entered; the checksum is automatically calculated; and the CRC16 value is automatically calculated. After you have finished inputting you can press the “Save” button, and save it as a text file of the txt type file extension, and can call out the file next time by pressing the “Open” button, and will not have to input it again. The “New” button will clear the input area, and allow you to begin inputting from scratch. Click the “X” icon on the upper right-hand corner or the “Close” button, and you can close the CRC16 calculator window.

13.2 Contact and Register Usage Information

Execute [Tool] → [Element Statistics] from the function toolbar and the [Element Statistics] window will appear:

The main intention for this feature is to allow the user to view the usage statuses of the various components in the project: used or unused. Select the “All” button, and then select the “X” component button, and all X components will be displayed, and all used components will have a check mark on the right-hand side of their reference numbers, as shown in the red frame in the illustration above. When this X component only appears in contact instruction, the “Contact” field on the right
will display a check icon in it, as shown in the blue frame in the above illustrations. If you select the “Y” button, and the Y component appears in contact and coil instructions, then a check icon will appear under the “Contact” and “Coil” fields on the right. Therefore, the “Contact”, “Coil”, and “Function” fields are used to show whether the selected component reference number appears in the relative instructions; the “Duplicate” field shows whether or not the selected component is repeatedly used; the “Function Implied” field shows whether this component is used in function block instruction, as shown below:

![Element Statistics](image)

### 13.3 System Backup

This feature can backup or recover the content of the Controller system in a very fast manner. This operation resembles that of saving the Controller contents to a file and therefore can be used as a Controller copy application. To use this feature, execute [Tool] → [System Backup] from the function toolbar when connected to the Controller:

![Backup Item Setup](image)

When the above window appears, the user can choose the items they wish to backup. After pressing the “OK” button, if the project has a password, then the user will be prompted to enter the password.
After the password has been confirmed, the system will request the protective options for backup and recovery, as shown below:

1. **No Protection:** When using this file for recovery, you will not need to enter a password.

2. **Node Locked Protection:** If this type of protection is chosen, when the user wishes to recover using this file, they will not need to enter a password, but will only be allowed to recover the current computer, and will not be allowed to recovery other computers. This feature is usually used in factory production conditions.

3. **Password Protection:** A password will be required to perform a recovery using this file.

After you have chosen the recovery protection options, press the "OK" button and the following dialogue box will appear:
After you enter the file name, press the "Save" button, and the following dialogue box will appear, and you can add notes to your backup file.

Press the "OK" button and the backup will begin.
13.4 System Restore

When the Controller is connected, execute [Tool] → [System Restore] from the function toolbar.

Choose the files with the ysb file extensions and you can perform system recovery, and the following illustration will appear.

If you have added notes to your backup file, this file description can be used for verification, and after you decide to use this backup file for recovery, press the "OK" button, and a password confirmation dialogue box will appear.

1. Ladder Password: enter the program password for the original protected program and you will be able to recover, but if the designer is unwilling to provide this password, you can choose to use an encryption password for user recoveries.

2. Encrypted Passwords: the encryption password randomly produces an encryption key, and WinProladder will
produce an encryption password according to this random value and the program password. Because WinProladder produces a different encryption key each time, therefore only those who know the program password can calculate an encryption password and perform file recovery. The advantage of this scheme is that backup file recovery can be performed without having to let the user know the program password, and because the random encryption key is different each time, each recovery encryption password is also used only once, which provides a further degree of protection for the intellectual property rights of the program designer.

If an encryption password is used, then the user that wishes to perform the recovery must give the encryption key shown in the window to a protector who knows the program password. The protector has to open a new WinProladder, and then executes [Tool] ➔ [Encrypted Password Generation]:

Enter the program password and the randomly produced encryption key into the dialogue box shown below:
Press the "OK" button to produce the encryption password.

The protector will then give this encryption password to the user that wishes to perform the recovery to enter into the password confirmation dialogue box, and the recovery operation can be proceeded with. The user must not close the password confirmation dialogue box before inputting has been completed or the encryption key will be different the next time it is opened.

Press the "OK" button and the restore will begin.
13.5 MEMORY Pack Operations

When connected with the Controller, execute [Tool] → [MEMORY_PACK operations] from the function toolbar and the following window will appear:

1. **Write program and data to MEMORY_PACK**: to execute the writing of program and data to MEMORY PACK.
2. **Erase MEMORY_PACK**: clears all program and data originally being written to the MEMORY PACK.
3. **Disable FLASH content loading when power on**: if you select this setting, then the program and data stored in MEMORY PACK will not be read during power-up.
4. **Enable FLASH content loading when power on**: if you select the normal mode settings, the program and data stored in MEMORY PACK will be read during power-up.

Four Operation Modes:

1. Write the program and registers to the MEMORY PACK. Press next and the following screen will appear:

If you need to retrieve the register data from the MEMORY PACK during each power-up, then you will need to define the initial and termination addresses. Press the "Add" button:
After creation, you may also click the “Edit” button to modify or you can also “Clear All” and then define a new one. After defining, press the “Execute” button and the writing will begin.
13.6 I/O Reference Number Allocation Statuses

WinProladder takes an automatic I/O address calculation for Controller main unit and expansion modules. After WinProladder connects with the Controller main unit, it will read the I/O installation status of the Controller main unit and the expansion modules, at the same time automatically allocating the I/O reference address for access. The user can view how many expansion modules are connected to the Controller main unit, and what the I/O addresses are used by the expansion modules in the project management window.

After you expand it, you will see the information for the expansion modules being installed:

The illustration above shows a WSZ-24MCT2-AC main unit has four expansion modules, which are WSZ-24XYT-AC, WSZ-24XYT-AC, FBs-TC6, FBs-RTD6 respectively, in which the I/O addresses used by WSZ-24XYT-AC, WSZ-24XYT-AC, FBs-TC6, FBs-RTD6 are as shown in the following table:

<table>
<thead>
<tr>
<th>Used system resources</th>
<th>DI</th>
<th>DO</th>
<th>IR</th>
</tr>
</thead>
<tbody>
<tr>
<td>WSZ-24XYT-AC</td>
<td>X14 ~ X27</td>
<td>Y10 ~ Y19</td>
<td></td>
</tr>
<tr>
<td>WSZ-24XYT-AC</td>
<td>X28 ~ X41</td>
<td>Y20 ~ Y29</td>
<td></td>
</tr>
<tr>
<td>FBs-TC6</td>
<td></td>
<td>Y30 ~ Y37</td>
<td>R3840</td>
</tr>
<tr>
<td>FBs-RTD6</td>
<td></td>
<td>Y38 ~ Y45</td>
<td>R3841</td>
</tr>
</tbody>
</table>
Besides obtaining the I/O address of expansion modules through the on-line method, WinProladder also provides users with a method of editing expansion module information off-line, which is described in the illustration below:

Right-click on [I/O Numbering], and select the "Add Module" option:

Location 1 represents that the connected expansion module is module number 1, which also means it is the first expansion module, and location 2 represents the second expansion module, and so on. Now, select the model types of the modules that you wish to install, add WSZ-24XYT-AC, WSZ-2DA, FBs-TC6 and FBs-RTD6 for example. Using this method, you can pre-edit the expansion modules that you wish to install during off-line.

The WinProladder software also displays the real installed expansion modules and manual edited modules.
Chapter 14 Import and Export Project Contents

Project contents that can be imported and exported include four types: [Comment], [Table], [Ladder Diagram], and [Status Page].

**Comment descriptions:** execute [File] → [Export] → [Comment] from the function toolbar; and the [Comment Export] window will appear. The exported file will be a text file, with txt file extension.

For the exported comments text files you can further execute [File] → [Import] → [Comment] from the function toolbar; and the [Comment Import] window will appear; select a text file and proceed with the import operation:

Please refer to Section 6.3 [Element Comment], where there is also a detailed description of these procedures.
**Table:** execute [File] ➔ [Export] ➔ [Export Table] from the function toolbar, and the [Table Export] window will appear.

Under the [Table List] option, select the table that you wish to export (for example, you may select "modbus") and then press the "Export" button, and save it as a file with a tab file extension, and you will have completed the table export procedure.

Execute [File] ➔ [Import] ➔ [Import Table] from the function toolbar; and the [Table Import] window will appear.

Select the filename that you wish to import, and press the "Import" button, and you will have completed the import operation.

**Ladder diagram:** if we wanted to copy network N001 from project one and paste it into project two, we could proceed as follows.

First, open project one, and select network N001, as shown in the following illustration:

Execute [File] ➔ [Export] ➔ [Ladder Diagram] from the function toolbar; and [Save As] dialogue box will be produced:
Enter the file name [sample] and then press "Save"; and an “Export Complete!” message will appear:

After you press the “OK” button, execute [File] →[Close Project] from the function toolbar, and close project one; then, open project two (to open the project, refer to the description on how to open existing files in Section 3.2), move your cursor to the position where you would like insert the network, and execute [File] →[Import] →[Ladder Diagram] from the function toolbar:

In the open file dialogue box, select the [sample.lrn] filename that you previously entered, and then press “Open”, and an “Import Completed!” message window will appear, and you have now completed a copy network operation between two different projects:
**Status Page:** execute [File] → [Export] → [Status Page] from the function toolbar; and the [Status Page Export] window will appear. Select "StatusPage0" in [Status Page List], and then press the "Export" button, and it will be saved as a file with the spf file extension, and now you have completed the status monitoring page export operations.

Execute [File] → [Import] → [Status Page] from the function toolbar; and the [Status Page Import] window will appear:

Select the status monitoring page filename that you would like to import, and then select the status monitoring page with new filename under the table list, press the "Import" button, and you will have completed the import operation. Open the [Status Monitoring] window of this project; and you will find that this status monitoring page has been created.
Chapter 15 Managing the Desktop

The WinProladder programming software has an easy-to-use Window interface, and there is an easy way to manage every aspect of the software, including the toolbar, project window, status monitor, and ladder diagram windows, etc., allowing even easier operations, and even neater displays.

15.1 Toolbar Management

Execute [View] → [Tool Bar] → [File] from the function toolbar; and the file toolbar icons will be displayed. If you execute this again, the file toolbar will be hidden:

Execute [View] → [Tool Bar] → [View] from the function toolbar; and the view toolbar will be displayed. Execute it again and the view toolbar will be hidden:

Execute [View] → [Tool Bar] → [Project] from the function toolbar; and the project toolbar icons will be displayed. Execute this again and they will be hidden:

Execute [View] → [Tool Bar] → [Ladder] from the function toolbar; and the component tray toolbar icon will be displayed. Execute this again and it will be hidden.

Use your cursor to drag open the portion of the toolbar encircled in red below and the toolbar icons will be brought out in an independent window, you can close this window by clicking on the “X” icon in the upper right-hand corner:

Similarly, if you drag the front portion of the toolbar, you can re-arrange all of the displayed toolbar icons:
15.2 Management of the Project Window

Execute [View] \(ightarrow\) [Project Tree] from the project window, and [Project Tree] will be displayed in the left-hand window in the WinProLadder programming software, as shown in the illustration below. You can close this project management window by pressing the “X” icon in the upper right-hand corner:

Similarly, by dragging on the portion marked in red in the above illustration, you can also create an independent project window, as shown in the illustration below, and you can close this window by clicking on the “X” icon in the upper right-hand corner:

15.3 Management of the Status Monitoring Page

Execute [Project] \(ightarrow\) [Status Page] from the function toolbar, and select the already existing monitoring page name “StatusPage0”, or, in the project window [Test example] \(ightarrow\) [Status Page] and select the already existing status monitoring page name “StatusPage0”, and the [Status Monitoring] window will appear, and all existing status monitoring page names will be listed in the monitoring window. You can bring out page contents by clicking on the various page labels, and you can close the [Status Monitoring] window by clicking on the “X” icon in the upper right-hand corner.
15.4 Management of Ladder Diagram Windows

Please refer to [The Order of Display for Ladder Diagram Display Windows] in Section 7.1.2 for detailed operation procedures.
Chapter 16 Common Q&A’s (FAQ)

**Question one:** Why can’t I connect with the Controller?

**ANS:** Please make sure that the set station number and communication parameters are correct; an error in any of them will result in failure to connect. If you are not sure whether or not the station number is correct, you can try the universal station number “255”, and then change it back to the station number you wish to use after you have successfully connected.

![Connection Setup](image1)

**Question two:** Why is it that even though I have finished writing the program, I cannot perform on-line operations with the Controller, and a “Project Information Does Not Match” warning window keeps appearing?

**ANS:** When the Controller is manufactured, its internal program areas are empty. If you try to open a project under this condition and execute connection items, WinProladder will compare your project program with the Controller internal program, and will only connect if the two programs are identical. Of course, if your Controller just came out of the factory, its contents must be empty, and no project will be able to connect to it, therefore, you should execute the “Save As” → “To PLC” option, instead of executing the “On-Line” option.

![Project Information](image2)
**Question three:** Why can’t I send an interrupt event inside the program, and how come when there is an interrupt, the interrupt service routine is not executed?

**ANS:** The reason for this is that although the interrupt label has been entered into the ladder program area, the interrupt input signal has not been defined in the I/O configuration settings page in the system configurations. Therefore, the way to solve this problem is to go to the I/O configuration settings page and define it, as shown below:

1. Enter the interrupt label and service routine in the sub ladder program area (the LBL frame will be highlighted in bold).

   ![Diagram of ladder logic with interrupts and LBL frames highlighted]

2. You will need to define the interrupt input in the I/O configuration page.

   ![Screenshot of I/O Configuration page with interrupt setup]
**Question four:** How come I used a high-speed pulse output function (FUN140) in the program, but there is no high-speed pulse output?

**ANS:** Some instructions in the WSZ-Controller main unit must be executed through self-developed ASIC, and therefore you need to tell the ASIC which jobs you want it to execute for you through the system configuration settings. So, please enter the I/O configuration setting page and make the required definitions, as shown below:

![Image showing I/O configuration setting page]

**Question five:** Why do the LED indicators light on immediately after the Controller executes, even when the corresponding output status should be 0?

**ANS:** You have probably accidentally set the output to an inverted state, making output coil that originally should not have conducted to invert, and therefore making the output indicators light up. Therefore, you should go to the I/O configuration setting page and select the correct output polarity.

![Image showing I/O configuration setting page]
**Question six:** In the I/O configuration setting page, I defined a high-speed hardware counter (HHSC0~HHSC3), but cannot see the corresponding registers (DR4096~DR4110) beginning to count?

**ANS:** If you want to use the hardware high-speed counter, besides doing the I/O configuration, you must also use the function instructions (FUN92, FUN93) to read and write the internal data from/to the ASIC. For details, please refer to Chapter 10 [WSZ-Controller High-Speed Counter and Timer] of User Manual II - Advanced Application.

**Question seven:** How do I download projects into the Controller?

**ANS:** Please follow the following steps.

**Step 1:** Use your mouse to select [File] → [Open] → [Open] or click the dropdown icon in the toolbar, and select [Open], or press the “Ctrl”+“O” key and the “Open” dialogue box will appear:

![Open Dialogue Box](image)

Then choose the file that you wish to open and press the “Open” button.

Or, select one of the four recently opened files provided by WinProladder, and you can quickly open one of the files you last opened. Use your mouse to select [File] → [Open] from the function toolbar (as shown in the illustration below):

![Function Toolbar](image)

Select the project that you wish to open. Follow the above steps to open existing file and display it in the ladder diagram window, as shown below:
(The program in the current ladder diagram window is only the program in the PC disk, and is not connected with the Controller)

Step 2: We can first save the program to the project files in the PC disk, please execute [File] → [Save] from the function toolbar, which means that the original project files will be saved; or, execute [File] → [Save As] → [Project File] from the function toolbar, and save the modified project program to a new project file. You can keep the original project.

Step 3: Since, in the beginning, an opened existing file is not connected to the Controller, therefore we need to connect to the Controller, and save the test program to the Controller, to be able to proceed with program testing. First execute [File] → [Save As] → [To PLC] from the function toolbar; and the [On-Line] window will appear:

(Select the desired [Connection Name], and then press the "OK" button, and the connection process will begin)
(After the connection has been established, the following illustration will appear)

(And now you can proceed with Controller connected tests)
Chapter 17 Appendix
This appendix contains the hotkey table and import/export format descriptions.

### 17.1 Hotkey Table

<table>
<thead>
<tr>
<th>Component input</th>
<th>Keys and descriptions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Contact A</td>
<td>A or Shift + A, if you simultaneously press the shift button you will only need to enter the component and will not need to enter the reference number</td>
</tr>
<tr>
<td>Contact B</td>
<td>B or Shift + B, if you simultaneously press the shift button you will only need to enter the component and will not need to enter the reference number</td>
</tr>
<tr>
<td>Transition Up Contact</td>
<td>U or Shift + U, if you simultaneously press the shift button you will only need to enter the component and will not need to enter the reference number</td>
</tr>
<tr>
<td>Transition Down Contact</td>
<td>D or Shift + D, if you simultaneously press the shift button you will only need to enter the component and will not need to enter the reference number</td>
</tr>
<tr>
<td>Output Coil</td>
<td>O or Shift + O, if you simultaneously press the shift button you will only need to enter the component and will not need to enter the reference number</td>
</tr>
<tr>
<td>Inverted Output Coil</td>
<td>Q or Shift + Q, if you simultaneously press the shift button you will only need to enter the component and will not need to enter the reference number</td>
</tr>
<tr>
<td>Set Coil</td>
<td>E or Shift + E, if you simultaneously press the shift button you will only need to enter the component and will not need to enter the reference number</td>
</tr>
<tr>
<td>Reset Coil</td>
<td>R or Shift + R, if you simultaneously press the shift button you will only need to enter the component and will not need to enter the reference number</td>
</tr>
</tbody>
</table>

Note: When entering the above components, you can first enter the reference numbers (X,Y,M,S,T,C) and then enter the component keys (A,B,U,D,O,Q,E,R), or you can first enter the component keys and then enter the reference number.

<table>
<thead>
<tr>
<th>Inversion of node status</th>
<th>i</th>
</tr>
</thead>
<tbody>
<tr>
<td>Transition Up of node status</td>
<td>p</td>
</tr>
<tr>
<td>Transition Down of node status</td>
<td>n</td>
</tr>
<tr>
<td>Horizontal Short</td>
<td>H</td>
</tr>
<tr>
<td>Continuous Horizontal Short</td>
<td>Shift + H</td>
</tr>
<tr>
<td>Vertical Short</td>
<td>V</td>
</tr>
<tr>
<td>Function Block</td>
<td>F</td>
</tr>
<tr>
<td>SET Function</td>
<td>Shift + S</td>
</tr>
<tr>
<td>RESET Function</td>
<td>Shift + R</td>
</tr>
<tr>
<td>Timer Function</td>
<td>Shift + T</td>
</tr>
<tr>
<td>Counter Function</td>
<td>Shift + C</td>
</tr>
<tr>
<td>Label Input</td>
<td>Shift + L</td>
</tr>
<tr>
<td>Repeat Last Input</td>
<td>Shift + F</td>
</tr>
</tbody>
</table>
### Component Editing

<table>
<thead>
<tr>
<th>Function</th>
<th>Keys and Descriptions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Modify contact reference number</td>
<td>Directly input new reference number, or press the “SPACE” key to bring up the editing window and then enter the new number.</td>
</tr>
<tr>
<td>Modify reference number in the function instruction</td>
<td>Press the “SPACE” key to bring up the editing window and then enter the new reference number.</td>
</tr>
<tr>
<td>Delete component or function instruction</td>
<td>Press the Delete key or the Backspace key.</td>
</tr>
</tbody>
</table>

### Network Editing

<table>
<thead>
<tr>
<th>Function</th>
<th>Keys and Descriptions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Insert blank network</td>
<td>Insert above – Shift + Insert</td>
</tr>
<tr>
<td></td>
<td>Insert below – Ctrl + Insert</td>
</tr>
<tr>
<td>Delete single network</td>
<td>Ctrl + Delete</td>
</tr>
<tr>
<td>Select networks in all program units</td>
<td>Ctrl + A</td>
</tr>
<tr>
<td>Copy network</td>
<td>Ctrl + C</td>
</tr>
<tr>
<td>Paste network</td>
<td>Ctrl + V</td>
</tr>
<tr>
<td>Delete network</td>
<td>Delete</td>
</tr>
<tr>
<td>Cut network</td>
<td>Ctrl + X</td>
</tr>
</tbody>
</table>

**Note:** Before performing the above four operations, you must first mark the network with your mouse.

### Cursor Movement

<table>
<thead>
<tr>
<th>Function</th>
<th>Keys and Descriptions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Up, down, right, left movement</td>
<td>The up, down, right, and left keys</td>
</tr>
<tr>
<td>Jump to first column</td>
<td>Home</td>
</tr>
<tr>
<td>Jump to last column</td>
<td>End</td>
</tr>
<tr>
<td>Jump to next row</td>
<td>Shift + Enter</td>
</tr>
<tr>
<td>Jump to next network</td>
<td>Enter</td>
</tr>
<tr>
<td>Jump to first network</td>
<td>Ctrl + Home</td>
</tr>
<tr>
<td>Jump to last network</td>
<td>Ctrl + End</td>
</tr>
<tr>
<td>Jump to a specific network</td>
<td>Ctrl + G</td>
</tr>
</tbody>
</table>
# Project Operations

<table>
<thead>
<tr>
<th>Function</th>
<th>Keys and descriptions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open new project</td>
<td>Ctrl + N</td>
</tr>
<tr>
<td>Open project file</td>
<td>Ctrl + O</td>
</tr>
<tr>
<td>Connect and open project</td>
<td>Ctrl + L</td>
</tr>
<tr>
<td>Save project</td>
<td>Ctrl + S</td>
</tr>
<tr>
<td>Print</td>
<td>Ctrl + P</td>
</tr>
</tbody>
</table>

# Controller Operation

<table>
<thead>
<tr>
<th>Function</th>
<th>Keys and descriptions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Stop Controller Operation</td>
<td>Ctrl + F9</td>
</tr>
<tr>
<td>Controller execution</td>
<td>F9</td>
</tr>
</tbody>
</table>

# Component Search

<table>
<thead>
<tr>
<th>Function</th>
<th>Keys and descriptions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Search for component</td>
<td>Ctrl + F</td>
</tr>
<tr>
<td>Search for next component</td>
<td>F3</td>
</tr>
</tbody>
</table>

# Miscellaneous Operations

<table>
<thead>
<tr>
<th>Function</th>
<th>Keys and descriptions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Set project options</td>
<td>Ctrl + F8</td>
</tr>
<tr>
<td>Syntax check</td>
<td>F8</td>
</tr>
<tr>
<td>Display register data</td>
<td>F11</td>
</tr>
</tbody>
</table>

# Step Ladder

<table>
<thead>
<tr>
<th>Function</th>
<th>Keys and descriptions</th>
</tr>
</thead>
<tbody>
<tr>
<td>STP</td>
<td>? (irrelevant to Caps Lock)</td>
</tr>
<tr>
<td>FROM</td>
<td>&lt; (irrelevant to Caps Lock)</td>
</tr>
<tr>
<td>TO</td>
<td>&gt; (irrelevant to Caps Lock)</td>
</tr>
<tr>
<td>STPEND</td>
<td>Shift + Z</td>
</tr>
</tbody>
</table>
17.2 Export/Import File Format

There are four types of project contents that can be exported and imported: [Comment], [Table], [Ladder Diagram], and [Status Page].

1. [Comment] The import/export file format is a text file with a txt file extension.
2. [Table] Import and export operations are performed in tab file extension format.
3. [Ladder Diagram] Import and export operations are performed in ldr file extension format.
4. [Status Page] Import and export operations are performed in spf file extension format.

The following is a description of the text file contents:

"REF": list component name fields.
"COMMENT": text comments for the corresponding components.
"DESCRIPTION": text descriptions for corresponding components.
**Revision History**

<table>
<thead>
<tr>
<th>Date of printing</th>
<th>Index</th>
<th>Description of revision</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dec. 2011</td>
<td>None</td>
<td>First version</td>
</tr>
<tr>
<td>Apr. 2012</td>
<td>a</td>
<td>Modification by the WSZ series lineup (WSZ-16YR, WSZ-4A2D, WSZ-16TC) addition</td>
</tr>
</tbody>
</table>